Bug report #10010

In Interpolation tool use z-coordinate should be unchecked before disable it

Added by Luca Casagrande over 5 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18498

Description

Test data:
https://dl.dropboxusercontent.com/u/348430/QGIS/test-data.zip

  1. Load both data inside QGIS and start interpolation tool
  2. Choose entities layer and check use Z-coordinates for interpolation
  3. Choose points layer and select column elev

The use Z-coordinate for interpolation is disabled (because the points layer is not 3d), but the checkbox is still checked.
This force the use of Z-coordinates.

This option should be unchecked before disable it.

Associated revisions

Revision 12252030
Added by Alexander Bruy over 2 years ago

[processing] uncheck Z-coordinate on layer change in Interpolation
algorithm (fix #10010)

History

#1 Updated by Alexander Bruy over 2 years ago

  • Priority changed from Low to Normal
  • Operating System deleted (Linux)
  • Category changed from Rasters to Processing/QGIS

#2 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#3 Updated by Alexander Bruy over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF