Bug report #9834

Atlas weird behaviour

Added by Antonio Locandro over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18365

Description

I have been using Atlas after Anita Graser told me about it, unfortunately I have found several bugs

1. Scale is not honored, I type a fix scale and it keeps resetting the scale
2. It works randomly, sometimes it works sometimes it doesn't
3. It doesn't work really good with openlayers base layers, it gives some nan extent things
4. After messing with options a lot sometimes it deletes the map composer view
5. I check the generate Atlas options, yet I have to check the map composer item controlled by Atlas option manually which seems not good UI/UX design

I have made two videos to try to show what's happening

https://www.dropbox.com/s/wikdwltr4mcshuu/screencast_%20%2801%29.mp4
https://www.dropbox.com/s/aj9zm0s4mw84ffn/screencast_%20%2802%29.mp4

Platform Windows 7 and 8 using 64 bit OSGEO4W installer and latest Master


Related issues

Related to QGIS Application - Bug report #9839: Atlas does not honor "fixed scale" Closed 2014-03-23
Related to QGIS Application - Bug report #9840: Using Atlas with OpenLayers results in nan extents Closed 2014-03-23
Related to QGIS Application - Bug report #9841: Atlas-controlled map vanishes randomly Closed 2014-03-23
Related to QGIS Application - Bug report #9842: Selecting Atlas-controlled map item is currently not user... Closed 2014-03-23

History

#1 Updated by Anita Graser over 6 years ago

  • Affected QGIS version changed from 2.2.0 to master
  • Category set to 33
  • Target version set to Future Release - Lower Priority

#2 Updated by Anita Graser over 6 years ago

Thanks for your input and the screencast. There is certainly a lot going on and I'll try to reproduce the issues to try get to the core of the problems.

In general, I think it is preferable to create one ticket per issue and try to provide instructions to reproduce the issue - if possible of course. But in this case, since you have one video summarizing most of the issues, this collection ticket makes sense to me.

A related issue might be: preview and atlas scales are not synchronized #9602

#3 Updated by Giovanni Manghi over 6 years ago

  • Category changed from 33 to Map Composer/Printing
  • Target version deleted (Future Release - Lower Priority)

I don't think that the OL layers is a QGIS/Atlas issue, if I'm not wrong the OL plugin does not supports printing.

#4 Updated by Anita Graser over 6 years ago

For now, I can't test the OpenLayers-related issues since adding OpenLayers layers crashes master #9649

#5 Updated by Anita Graser over 6 years ago

@Giovanni: I'm unsure if OL should support printing or not, see #6653 which argues that it should work.

#7 Updated by Anita Graser over 6 years ago

ad point 1: "Fixed scale" seems to work fine with metric CRS (e.g. EPSG:3035) but scale changes when WGS84 is used as a project CRS.

#8 Updated by Anita Graser over 6 years ago

  • Assignee set to Nyall Dawson

#9 Updated by Nyall Dawson over 6 years ago

Can this please be split into multiple issues before too much discussion occurs? It's going to get very messy otherwise!

#10 Updated by Anita Graser over 6 years ago

@Nyall: Can any of the 5 issues be discarded or should I open a ticket for each?

#11 Updated by Nyall Dawson over 6 years ago

Perhaps number 3 (open layers related), but may as well make it too and I'll see what's happening there.

#12 Updated by Anita Graser over 6 years ago

  • Status changed from Open to Closed

Ok, I created 4 tickets. Didn't quite know what to do with the 2nd one ...

I guess I'll close this one now.

#13 Updated by Nyall Dawson over 6 years ago

Thanks Anita! I think number 2 might just be a bit more info for number 1, at least that's how I interpreted it.

Also available in: Atom PDF