Bug report #9602

preview and atlas scales are not synchronized

Added by Denis Rouzaud over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:High
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18180

Description

If your atlas has a fixed scale, when you change the scale in the preview it does not change the atlas, which is confusing.
Hence, to change the atlas scale, one must:
1. disable atlas
2. modify scale
3. re-enable atlas.

The two should be synchronized.

Associated revisions

Revision f252a965
Added by Nyall Dawson over 5 years ago

[composer] Scale changes while in atlas fixed scale mode are permanently applied (fix #9602)

History

#1 Updated by Nyall Dawson over 5 years ago

I've been thinking about a possible solution to this. How do you feel about me adding a text input next to the map's atlas "fixed scale" option, which allows the fixed scale to be set? This has the benefits:
- All settings which affect atlas extents are grouped together (along with margin around scale, the scaling mode radio buttons)
- We still maintain the useful feature that during an atlas preview the extent and scale of a map can be temporarily modified without affecting the map for other features in the atlas

What's your thoughts?

#2 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Feedback

#3 Updated by Denis Rouzaud over 5 years ago

The main problem I see is that it won't be WYSIWYG anymore.
Also, I think it's confusing to have to scale fields.

I don't see a real interest of leaving a different scale in the composer.
You can zoom in/out to see something and go back to the fixed scale.

I think it's the simplest and clearest.

#4 Updated by Nyall Dawson over 5 years ago

The issue is that any changes to the scale would then be permanant and apply to the entire atlas. You'd lost the ability to temporarily override the scale for a single feature/page. The alternative would be for a dialog asking the user if they want scale changes to apply to the atlas or just the current feature, but that sounds like bad ux to me...

#5 Updated by Denis Rouzaud over 5 years ago

On the contrary, I don't think this is problem.
If you change it, it means it was changed for the whole atlas.
The problem with what you proposed first is that you won't print what is shown on the screen and this should be avoided.
I agree that second alternative is really bad design.
Later when scale would be possibly data-defined, it won't be a problem anymore. If a single should have a different scale, you will define it in a field.
For me:
- keep the config as simple as possible: don't add new checkbox (e.g. do this in such case)
- keep it WYSIWYG
That's why I'm quite convinced that there should be only one scale definition.
But you seem quite convinced too ;)

#6 Updated by Nyall Dawson over 5 years ago

  • Status changed from Feedback to In Progress

Actually - you're right. I was working using this feature today and have come around to your way of thinking ;) It's not a trivial change, but I'll try to implement it for 2.4

#7 Updated by Denis Rouzaud over 5 years ago

Glad to hear!
I hope you can make it!

#8 Updated by Nyall Dawson over 5 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF