Bug report #9809

xls / xlsx field names are imported as first line

Added by Regis Haubourg over 5 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Data Provider/OGR
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:18345

Description

Hi, In master and 2.2, xls and xlsx field names are imported as first line.
To me, it is a blocker, even if I don't mark it so. I probably will have to downgrade to 2.0 here.
Backport more than welcome.
This is probably related to OGR_XLSX_HEADERS option.

History

#1 Updated by Alexander Bruy over 5 years ago

Sometimes field names imported correctly, but I can't find any dependency

#2 Updated by Regis Haubourg over 5 years ago

Hi,
a user raised that when explicitly defining field names line as text in spreadsheet software solves the issue.
Hope that helps
Régis

#3 Updated by Jürgen Fischer about 5 years ago

  • Category changed from Data Provider to Data Provider/OGR

#4 Updated by Even Rouault about 3 years ago

  • Status changed from Open to Feedback

@regis Is the issue still uptodate ? Is there any file to reproduce you could attached ?

#5 Updated by Giovanni Manghi almost 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

Even Rouault wrote:

@regis Is the issue still uptodate ? Is there any file to reproduce you could attached ?

I can't find an example it does not work as expected in a recent qgis release (2.14 or 2.18 with gdal 2.*).

Closing for lack of feedback, please reopen if necessary.

#6 Updated by Regis Haubourg almost 3 years ago

Hi sorry for the lag again, I quit my previous work and do not have test data anymore. I suspect the issue is not there anymore anyway.

Also available in: Atom PDF