Bug report #9691

Rotation of ESRI Shapefile with transparency in Print Composer

Added by Tut halija over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18256

Description

By rotating a map [add image] in the print composer [Item Proprieties -> Main Proprieties -> Map -> Map rotation], when the transparency of Shapefile layer (in the project) is not set at 0, gives a mistake if you're exporting the file.

That doesn't occur if the transparency of the layer in the project is set to "0" or for raster with/without transparency.

Enclosed screenshot of the print composer (the map is cached) and the output with rotation of 330 degrees. The transparency of the green layer is set at 5%, 0% for the red. You can see how the green layer is cut (it should looks like the print composer) and how the other layer are fine.

Hint: You can see that the Shapefile with transparency doesn't follow the rotation

PrintComposer.jpg - Green Shapefile layer with transparency set at 5% over Shapefile and Raster layer with transparency set at 0 in the print composer (185 KB) Tut halija, 2014-03-03 01:34 AM

ExportedFile.jpg - Exported file from the Print Composer: Green Shapefile layer doesn't make the rotation. (303 KB) Tut halija, 2014-03-03 01:34 AM

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Target version set to Version 2.4
  • Category set to Map Composer/Printing

#2 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Feedback

Can you confirm whether you still see this issue in current master (v 2.3)? I can't reproduce this issue and suspect it has been fixed.

#3 Updated by Tut halija over 5 years ago

Dear Nyall

I tested on current master (v. 2.3). The issue has been fixed. Great!
Thanks a lot, I was really looking for the implementation.

Should I close the bug report ? (sorry I am a newbie, it's my first bug report)

Néhémie

#4 Updated by Nyall Dawson over 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF