Bug report #963

The project Save? dialog does not appear when expected.

Added by Steven Mizuno about 12 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Project Loading/Saving
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11022

Description

A project with layers loaded sometimes doesn't get the Save dialog on closing QGIS/new file/open file actions

The Ask to save project changes... option is enabled.

One sequence of steps that does cause the Save? dialog to appear:
1. with any project (file or new) click one of the Zoom buttons (don't need to actually do any zooming - it is the button click action setting a "dirty" flag.)
2. close QGIS

Most other actions on the project, like adding a layer, don't cause the Save? dialog to appear.

This occurs in HEAD and back to 0.9.0, and on Windows and Linux.

When I noticed this I decided to write down exactly what I was expecting so I could test each scenario more intelligently than just randomly clicking buttons and such.

I poked around in the Developers area of the wiki and couldn't find anything outlining expected behavior on this topic. Perhaps I am looking in the wrong place. The user manual doesn't really address this, just a mention of the Ask to save project changes option.

So, I have attached my list of expectations for the Save? dialog to appear (or not) Comments?

QGIS-expected_behavior_-_Save_dialog.txt Magnifier - expectations for the Save? dialog to appear (2.9 KB) Steven Mizuno, 2008-02-28 06:30 PM

History

#1 Updated by Paolo Cavallini almost 11 years ago

I confirm: if I remove a layer from a project, I can close QGIS without a question

#2 Updated by luca76 - over 10 years ago

I cannot reproduce it:

1) new project
2) add a shapefile
3) zoom

closing QGIS asks me if I want to save...

#3 Updated by Paolo Cavallini over 10 years ago

I can confirm the defect: if you add a layer to an existing project, you are not asked to save it when closing.

#4 Updated by Giovanni Manghi over 10 years ago

Tested now on f81780d2 (SVN r12280): adding a layer now seems to work. If you try close qgis it ask you if you want to save the changes.

Removing a layer still doesn't work as expected: you can remove a layer from a just saved project and then close qgis. No question will pop up asking to save the project.

#6 Updated by Jürgen Fischer over 10 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

fixed in b1e241a0 (SVN r12927). maybe just partly. issues from #2431 are covered. if there are any other actions that modify the project so that it should be save, please name them (like in #2341).

#7 Updated by dr - over 10 years ago

If move disabled layer in TOC to new place then The project Save? dialog does not appear.

Also available in: Atom PDF