Bug report #9503

Fill patterns are clipped when exporting rotated composer to PDF

Added by Ed B almost 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18094

Description

In my composer I have a map with only a polygon shapefile layer. The map is rotated to 290 degrees. The polygon layer has some styling applied (qml file attached below).

To replicate:
-Add shapefile
-Apply QML style using "Load Style..."
-Create new composer
-Set paper to ANSI A, Portrait
-Add map to composer and change map rotation to 290 degrees
-Modify extents to match image from below
-Export to PDF
-You will get a message box about composition effect and Print as Raster will be checked, click close
-Save PDF to somewhere
-Review PDF and you should see along the top of the page part of the polygon is clipped.

wm.qml - Layer Style (14.5 KB) Ed B, 2014-02-06 11:44 AM

polygons.zip - Sample Shapefile (12.3 KB) Ed B, 2014-02-06 11:44 AM

extents.PNG - Extent Info (12 KB) Ed B, 2014-02-06 11:44 AM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Target version set to Version 2.2
  • Priority changed from High to Normal

There is no crash or data corruption, so I'm lowering the priority.

#2 Updated by Giovanni Manghi almost 6 years ago

  • OS version deleted (64 bit)
  • Affected QGIS version changed from 2.0.1 to master
  • Operating System deleted (Windows 7)

#3 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Feedback

Can you confirm whether you still see this issue in current master (v 2.3)? I can't reproduce this issue and suspect it has been fixed.

#4 Updated by Ed B over 5 years ago

I can confirm it has been fixed, please close.

#5 Updated by Nyall Dawson over 5 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF