Feature request #9488

Rounded frames in the composer

Added by mathieu rajerison almost 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Pull Request or Patch supplied:No Resolution:fixed/implemented
Easy fix?:No Copied to github as #:18079

Description

If you want some rounded frames in the composer, you have to import an SVG or an image of it.

It would be nice to apply rounded edges on frames directly from the Label parameters.

History

#1 Updated by Mathieu Pellerin - nIRV almost 7 years ago

Hi Mathieu, this is Mathieu :)

See a recent issue I filed on this: #9479

Maybe this could be closed as duplicate of the above. As for a work around on rounded edge, you can - under upcoming 2.2 - now use a basic rectangle shape and style it using outline: simple line symbology to get rounded corners (or straight corners, for that matter).

#2 Updated by mathieu rajerison almost 7 years ago

okay Mathieu.
I had checked before posting but searched for "rounded" but not "round" word. So I hadn't seen the previous issue.

Sorry :)

#3 Updated by Nyall Dawson over 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Think this can be closed now - master has the ability to draw rounded rectangles, and control the join style of item frames (bevel/miter/round).

Also available in: Atom PDF