Bug report #9392

Ortho Projection produces artifacts

Added by achim tack almost 6 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Projection Support
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17990

Description

I`m trying to create a sphere-like view using qgis and the "world from space"-projection http://spatialreference.org/ref/sr-org/6980/ (essentialy an ortho-projection). ArcGIS wraps the shapes correctly but QGIS (2.01) produces nasty artifacts.

Currently for this to work you'll need to crop your layer before projecting it: Project your shapefile to an azimuthal equidistant projection with the same parameters as the orthographic projection, create a clipping circle that covers the hemisphere that will be visible in the orthographic projection, and clip the shapefile with that. However, that method requires a fair bit of manual effort, and doesn't work for all projection parameters, since projecting to an azimuthal equidistant projection can lead to similar problems as projecting to an orthographic projection.

1VNJA.png (164 KB) achim tack, 2014-01-21 01:45 AM

Associated revisions

Revision 454cce89
Added by Nyall Dawson over 1 year ago

Don't try to render non-finite points

They occur as a result of reprojection errors, and cause a line
to be extend to the top-left of the canvas.

Fixes #9392

Revision 7b7f915a
Added by Nyall Dawson over 1 year ago

Don't try to render non-finite points

They occur as a result of reprojection errors, and cause a line
to be extend to the top-left of the canvas.

Fixes #9392

(cherry-picked from 454cce89)

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback
  • Target version set to Future Release - High Priority
  • Category set to Projection Support

Maybe the issue described in paragraph 12.1.6 (of the QGIS 2.0) user manual does help solve the issue?

#2 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Open
  • Affected QGIS version changed from 2.0.1 to master

#3 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#4 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

#5 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to fixed/implemented
  • Description updated (diff)

Also available in: Atom PDF