Feature request #9281

[composer] add option to disable antialiasing when exporting compositions

Added by Giovanni Manghi over 5 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Pull Request or Patch supplied:No Resolution:fixed/implemented
Easy fix?:No Copied to github as #:17893

Description

To be more precise, it seems that when printing the option is set always as active, no matter if printing as raster or not.

Associated revisions

Revision 2f0969e2
Added by Nyall Dawson over 1 year ago

Expose antialiasing option in image export dialog

Allows for creating non-antialiased images from layouts. Note that
some layout item types do not correctly respect this setting, but
at least map items do and the API is in place for them to be
fixed later.

Fixes #9281

History

#1 Updated by Jürgen Fischer over 5 years ago

  • Subject changed from The option "make lines apperar less jagged at the expense of some drawing performance" does not seems to be applied in the print composer to The option "make lines appear less jagged at the expense of some drawing performance" does not seems to be applied in the print composer

#2 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Feedback

I don't think this is a bug - to me it's a feature. Why would you want to disable anti-aliasing when exporting a composition?

#3 Updated by aperi2007 - over 5 years ago

The antialiasing if no good for the black-white TIFF4 images.

In the tiff4 the main goal is have always only two color black/white.
The antialiasing work substituting some white pixel with a grey light color.
This break the possibility to have a tiff4 image.

As a use case:
the composer will allow the opportunity to export a map as a tiff georef.

But if the goal is to export a tiff4 black/white image.
The acutal setting of composer to deny the correct black/white will deny to have a set of tiff4 images georef as exportation from qgis.

#4 Updated by aperi2007 - over 5 years ago

So it is definitively a bug because It donnot reproduce exactly what there is in the canvas.

The goal of composer is produce a print of what there is on canvas .
A composer that da another think differente from canvas is not a print in qgis, but a different program.
In the canvas there is a black/white image because I can put the white transparent and having a result when export.
In composer when export I have a raster not black/white.

So I guess it is a bug.

#5 Updated by Nyall Dawson over 5 years ago

  • Category changed from 33 to Map Composer/Printing
  • Tracker changed from Bug report to Feature request
  • Subject changed from The option "make lines appear less jagged at the expense of some drawing performance" does not seems to be applied in the print composer to [composer] add option to disable antialiasing when exporting compositions

OK, that's a good point. However I don't think the existing option for antialiasing in settings is the correct solution. For one, this option is worded in a way that makes it sound like its purely for performance. I'd imagine the given how its worded the current use case is that people are disabling antialiasing in settings to speed up working with the canvas , not to change how maps are exported.
Secondly, this current setting has no effect on other composer controls such as labels, etc.
I think your use case could be better addressed by an option in the composition settings for disabling antialiasing for the whole composition. This option would be per composition, not a global setting.

#6 Updated by Paolo Cavallini over 5 years ago

  • Priority changed from Normal to High
  • Target version changed from Future Release - High Priority to Version 2.2

Sounds reasonable. Nevertheless, I think this option should be added, as without it the user case described is seriously hindered. As it solves a real user issue, quite important in massive production, and it should not impact other code, I would ask to reconsider adding it to the upcoming version.

#7 Updated by Giovanni Manghi about 5 years ago

  • Target version changed from Version 2.2 to Version 2.4
  • Status changed from Feedback to Open

#8 Updated by Jürgen Fischer about 5 years ago

  • Target version changed from Version 2.4 to Future Release - High Priority

#9 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#10 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

#11 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF