Bug report #9244

Paste in place doesn't work across pages anymore

Added by Olivier Dalang over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17862

Description

In 2.0, when working on multi-pages composers, you could copy-in-place an item from a page to another (the item would be copied at the same position, but on the page which is under the mouse).

This does not work anymore in 2.1.

Since it's a regression, I flag it as blocker (right?)

Associated revisions

Revision 9aa4155e
Added by Nyall Dawson over 6 years ago

[composer] Paste in place should put items in page which cursor is over (fix #9244)

History

#1 Updated by Nyall Dawson over 6 years ago

  • Assignee set to Nyall Dawson

#2 Updated by Nyall Dawson over 6 years ago

  • Affected QGIS version changed from 2.0.1 to master

#3 Updated by Nyall Dawson over 6 years ago

  • Status changed from Open to Feedback

I can't replicate this... are you able to re-test and give me steps to reproduce it? Thanks!

#4 Updated by Nyall Dawson over 6 years ago

  • Category set to Map Composer/Printing

#5 Updated by Olivier Dalang over 6 years ago

Steps to reproduce (tested in 06b1fbc):

1) create a new file
2) create a new composer
3) set number of pages to 2
4) create a rectangle on the first page
5) copy that rectangle
6) move the mouse cursor to the second page (hover only, no click involved)
7) paste in place (ctrl+shift+v)

In 2.0.1, the rectangle was pasted on the same position but on the second page.
In master, the rectangle is pasted over the first one.

#6 Updated by Nyall Dawson over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF