Bug report #9135

PostGIS - materialized views only show if "also list tables with no geometry" is ticked

Added by Nyall Dawson over 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:17770

Description

PostGIS materialized views are not shown in the "Add PostGIS table" dialog UNLESS "also list tables with no geometry" is ticked, even if they have geometry columns.

Expected behaviour is that materialized views would show with "also list tables with no geometry" UNTICKED if they do have a geometry column.


Related issues

Related to QGIS Application - Feature request #8791: Support PostgreSQL materialized views Closed 2013-10-07
Related to QGIS Application - Bug report #9136: Browser does not show Postgres materialized views Closed 2013-11-27

History

#1 Updated by Jürgen Fischer over 6 years ago

  • Affected QGIS version changed from 2.0.1 to master

Not reproducable here using PostgreSQL 9.3 with PostGIS 2.1. Here materialized views only disappear when 'Only look in layer registries' is checked.

#2 Updated by Nyall Dawson over 6 years ago

Do you have "Don't resolve type of unrestricted columns (geometry)" ticked? (I do). Perhaps this bug is only triggered when that is ticked..?

#3 Updated by Jürgen Fischer over 6 years ago

Nyall Dawson wrote:

Do you have "Don't resolve type of unrestricted columns (geometry)" ticked? (I do). Perhaps this bug is only triggered when that is ticked..?

No. But that can also cause this as materialized views also don't have geometry type constraints.

#4 Updated by Matthias Kuhn over 6 years ago

Is this an issue that will be solved? Or maybe it needs some hints on the GUI/help side?

#5 Updated by Jürgen Fischer about 6 years ago

  • Category set to Data Provider/PostGIS
  • Status changed from Open to Feedback

Matthias Kuhn wrote:

Is this an issue that will be solved? Or maybe it needs some hints on the GUI/help side?

I can't reproduce it. I see a materialized views when "Also list tables with no geometry" is not checked - whether or not I check "Don't resolve type of unrestricted columns (geometry)" doesn't matter.

#6 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF