Bug report #9100

Processing Distance Matrix tool not working

Added by Jonathan Moules about 7 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:17745

Description

1) Add the attached "points" shapefile.
2) Use the Processing toolbox Distance Matrix - configure as attached screenshot.
3) Press Run.

For me at least, the dialog disappears and then absolutely nothing happens. No errors, no alerts, nothing in the logs.

==========
There's a second failure mode too. If the output matrix type is "standard", I get a python error instead:

Traceback (most recent call last):
File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\\processing\\core\\GeoAlgorithm.py", line 150, in execute
self.processAlgorithm(progress)
File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\\processing\\algs\\ftools\\PointDistance.py", line 98, in processAlgorithm
self.regularMatrix(inLayer, inField, targetLayer, targetField, nPoints, progress)
File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\\processing\\algs\\ftools\\PointDistance.py", line 178, in regularMatrix
data.append(unicode(outFeat.attributes[outIdx]))
TypeError: 'builtin_function_or_method' object has no attribute '__getitem__'

points.zip (6.12 KB) Jonathan Moules, 2013-11-20 03:44 AM

Clipboard01.png (32.2 KB) Jonathan Moules, 2013-11-20 03:45 AM

History

#1 Updated by Jonathan Moules about 7 years ago

#2 Updated by Filipe Dias about 7 years ago

Can you also test with a more recent code revision? It's available via the Plugin Installer.

#3 Updated by Jonathan Moules about 7 years ago

Due to proxy issues I can't access the plugin installer. Sorry.

#4 Updated by Alexander Bruy about 7 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Works in master.

Please, don't post Processing issues in QGIS tracker!

#5 Updated by Jonathan Moules about 7 years ago

Alexander Bruy wrote:

Works in master.

Please, don't post Processing issues in QGIS tracker!

a) There is a "Processing (SEXTANTE)" category on this tracker
b) How many trackers are there for all of the components of QGIS? How is a user supposed to find them all and know what goes in what tracker? QGIS has tons of disparate components.

#6 Updated by Filipe Dias about 7 years ago

This is the Processing's bug tracker. I believe the idea is to clean the current Processing bugtracker and then merge it with the main bugtracker.

https://issues.qgis.org/projects/sextante/issues

If you wish to use the most recent code with 2.0.1, you can go to Github, download the code and copy the folder python/plugins/processing and replace on your installation.

#7 Updated by Alexander Bruy about 7 years ago

Jonathan Moules wrote:

b) How many trackers are there for all of the components of QGIS? How is a user supposed to find them all and know what goes in what tracker? QGIS has tons of disparate components.

Go to "Projects" page and you will see all available trackers. If you post bug in wrong tracker there is a big chance that it will be never fixed.

#8 Updated by Jonathan Moules about 7 years ago

Alexander Bruy wrote:

Go to "Projects" page and you will see all available trackers. If you post bug in wrong tracker there is a big chance that it will be never fixed.

I wasn't aware of that page. Thanks.

#9 Updated by Jonathan Moules about 7 years ago

Have downloaded the 2.1 weekly and "standard" is still broken, though in a slightly different way. "Linear" is also still a bit buggy. Will open tickets elsewhere.

#10 Updated by Giovanni Manghi over 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF