Bug report #8959

wms failing to show valid epsg:4326 layers in QGIS2 (working in 1.8)

Added by Richard Duivenvoorde about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17623

Description

When strk asked for a epgs:4326 wms service, I thought to show him the osgeo-wms service url:

http://vmap0.tiles.osgeo.org/wms/vmap0

After the getcapabilities, in QGIS 2.0 the layers-dialog show NAD83 with all layers.
But when selecting epsg:4326 (which IS a valid srs according to the capabilities):

http://vmap0.tiles.osgeo.org/wms/vmap0?LAYERS=basic&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetCapabilities

all layers are greyed out (and not selectable).
Both in QGIS 2.0 as in current master.

In QGIS1.8 it is working normally IF i tick both Ignore Get* checkboxes. If ommiting this, you'll receive a mapserver error msg back).
A valid epsg:4326 map is shown here.

01.png (186 KB) Richard Duivenvoorde, 2013-10-28 02:39 AM


Related issues

Duplicates QGIS Application - Bug report #8298: CRS change with recently used CRS makes no effect in the ... Closed 2013-07-14

History

#1 Updated by Richard Duivenvoorde about 6 years ago

some more testing (see screenshot).

I had a CRS-selector dialog which showed EPSG:900913 and EPSG:4326 in the upper (recently used crs's) panel. So I clicked that one (as I do normally I think). and you will end up with the message 'no CRS selected'.

BUT if I search for EPSG:4326 and select it in the lower panel I get a map.

#2 Updated by Richard Duivenvoorde about 6 years ago

  • Status changed from Open to Closed

nobody can confirm it. So it seems that my crs selector lists of the 'recently used crs's' and the list from the lower panel are in one way or another not linked anymore?

Will close this one.

#3 Updated by Paolo Cavallini about 6 years ago

  • Status changed from Closed to Reopened

I confirm it here, not only on WMS.

#4 Updated by Giovanni Manghi about 6 years ago

if it is a regression tag this as blocker, thanks.

#5 Updated by Jukka Rahkonen about 6 years ago

Works for me with QGIS 2.0.1 on 32-bit Windows with no troubles when using EPSG:4326.

#6 Updated by Giovanni Manghi about 6 years ago

  • Category changed from Web Services clients/WMS to GUI
  • Status changed from Reopened to Feedback
  • Target version set to Future Release - High Priority

Richard Duivenvoorde wrote:

some more testing (see screenshot).

I had a CRS-selector dialog which showed EPSG:900913 and EPSG:4326 in the upper (recently used crs's) panel. So I clicked that one (as I do normally I think). and you will end up with the message 'no CRS selected'.

BUT if I search for EPSG:4326 and select it in the lower panel I get a map.

Hi Richard,

now from this description I understand better the issue.

This has nothing to do with WMS (as Paolo said).

The things that right now in many CRS selection dialogs, when choosing the CRS from the "last used list" it WON'T work.

You must click one, the click another... the second time it works.

Selecting the CRS from the complete list in the bottom half of the dialog it works always.

This is duplicate of another ticket that I can't find right now.

Please close this as soon as you find the other one. Cheers!

#7 Updated by Richard Duivenvoorde about 6 years ago

  • Status changed from Feedback to Closed

I think you mean #8298

will close this one

Also available in: Atom PDF