Bug report #8872

Create ring in multipart polygon fails

Added by Jonathan Moules almost 7 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17552

Description

If I try and create a ring in a multipart polygon (advanced digitising), it fails with the error "The inserted Ring is not contained in a feature". But it is in a feature. I suspect it is failing because it is multiparted. The error should say this if it's not meant to work in them.

History

#1 Updated by Nyall Dawson almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Not reproducible in current master

Also available in: Atom PDF