Bug report #8825

OpenLayers plugin print bug

Added by Mikhail Tchernychev over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:17518

Description

While using OpenStreet layers with print composer and projection different from
Pseudo Merkator (EPSG 3857 ) layers are misplaced in PDF output.

Here is how to reproduce the problem.

1. Load costline.shp file, set project projection as WGS UTM zone 17
2. Add OpenStreet layer (any)
3. Make sure that project CRS is still set to UTM (EPSG 3261).
4. Go to print composer. Everything looks good.
5. Make PDF file. Note that SHP coastline is shifted considerably.

OpenStreet plugin is very useful, but EPSG 3261 is not really
production projection.

Thank you very much,
Mikhail

coastline.zip - See PNG / TIFF files and PDF files for position difference (2.5 MB) Mikhail Tchernychev, 2013-10-11 12:43 PM

coastline.zip (2.5 MB) Mikhail Tchernychev, 2013-10-11 12:53 PM


Related issues

Duplicates QGIS Application - Bug report #8824: Exported image from OpenLayer plugin looks shifted no mat... Closed 2013-10-11

History

#1 Updated by Mikhail Titov over 6 years ago

I think it is a duplicate of #8824 that I filed just before.

#2 Updated by Mikhail Tchernychev over 6 years ago

Yes it is duplicate. We were writing it at the same time..

I updated my example file because it turns out I did not save SHP...

#3 Updated by Alexander Bruy over 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate #8824

Also available in: Atom PDF