Feature request #8706

Diagram placement: make "Show all" the default, and easier to change

Added by Paolo Cavallini about 4 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Pull Request or Patch supplied:No Resolution:
Easy fix?:No

Description

While the default of not showing overlapping elements makes sense for labels, it is less reasonable for diagrams, where a partial overlap is better than missing some.
Furthermore, the option to show them all is hidden in obscure (for average user) options.

My suggestions:

  • enable "show all" by default
  • put the option to remove the overlapping ones in the main dialog, easy to find.

Associated revisions

Revision d7eec444
Added by Nyall Dawson over 2 years ago

[FEATURE] Add checkbox to always show diagrams for a layer

Unlike the global labeling setting this applies only to diagrams,
and only for a single layer. Defaults to on. (fix #8706)

History

#1 Updated by Giovanni Manghi about 4 years ago

  • Target version set to Future Release - High Priority

#2 Updated by Marek Michalski about 4 years ago

Thank You very much. I've found "show all" option for charts after two hours or so spent with google ;-) So, it's not a bug, it's feature...
Your suggestions are OK, this option should be visible in main dialog and enabled by default.

#3 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF