Bug report #8705

Duplication of Composer should inherit custom paper size

Added by Mikhail Titov about 6 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17424

Description

Steps to reproduce:

  1. Create composer
  2. Adjust paper size in Composition tab, e.g., 4"x6"
  3. Save(?)
  4. Duplicate composer

Paper size will reset to A4

Associated revisions

Revision 7343b36e
Added by Nyall Dawson over 3 years ago

[composer] Load all composition properties from template/duplicate

Previously some settings where not being correctly restore, eg
page size, grid settings, expression variables

On behalf of Faunalia, sponsored by ENEL

Fix #8705

Revision 5ee88802
Added by Nyall Dawson over 3 years ago

[composer] Load all composition properties from template/duplicate

Previously some settings where not being correctly restore, eg
page size, grid settings, expression variables

On behalf of Faunalia, sponsored by ENEL

Fix #8705

(cherry-picked from 7343b36e2574a9d9b16158911adaaf6b9d3740be)

Revision 118e3332
Added by Nyall Dawson over 3 years ago

[composer] Load all composition properties from template/duplicate

Previously some settings where not being correctly restore, eg
page size, grid settings, expression variables

On behalf of Faunalia, sponsored by ENEL

Fix #8705

(cherry-picked from 7343b36e2574a9d9b16158911adaaf6b9d3740be)

Revision d5255125
Added by Nyall Dawson over 3 years ago

[composer] Load all composition properties from template/duplicate

Previously some settings where not being correctly restore, eg
page size, grid settings, expression variables

On behalf of Faunalia, sponsored by ENEL

Fix #8705

(cherry-picked from 7343b36e2574a9d9b16158911adaaf6b9d3740be)

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Operating System deleted (win32)
  • Target version changed from Version 2.0.0 to Future Release - High Priority

#2 Updated by Larry Shaffer about 6 years ago

Hi Mikhail,

If you work with master branch builds, please test "commit 121d76e2a":#121d76e2

It works for me on Mac. While working on the fix, I noticed other settings are not duplicated, e.g. DPI, number of pages, etc. for composition. I have a fix for that, but am currently testing it.

#3 Updated by Nyall Dawson almost 6 years ago

Larry,

How'd you go with your fix for the other settings? Do you have a public branch I can test?

#4 Updated by Nyall Dawson over 3 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF