Bug report #8693

Non-descriptive names in GDAL/OGR tools

Added by Jonathan Moules almost 7 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:17414

Description

The GDAL tools (Advanced interface) mostly don't have descriptive names. Almost every other tool from other sources do - the GRASS ones in particular.
But the GDAL ones have "fillnodata" "proximity" "sieve" "pct2rgb", etc...
These will no doubt mean something to someone who knows GDAL, but to a non-user (i.e. me), they don't.

History

#1 Updated by Alexander Bruy almost 7 years ago

I'm disagree (or partly agree). Most tools use same names as tools from "Raster" menu.

#2 Updated by Jonathan Moules almost 7 years ago

Of the wrong ones listed on the GDAL menu, the only one of them I can see on the raster menu (simplified interface) is "proximity". Which is wrong on both because it should have a capitalised P. ;-)

None of the other wrong ones (all of which start with a lower case character) are on the Raster list as best I can tell.
Or are you referring to a different raster menu?

#3 Updated by Filipe Dias almost 7 years ago

I agree with Jonathan. The names should be the same on Processing and Raster. Even more so if the devs decide to get rid of Vector/Raster menus in favor of keeping all analytical tools under Processing.

#4 Updated by Alexander Bruy over 6 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in master

#5 Updated by Giovanni Manghi about 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF