Bug report #8691

Inconsistent icons in Processing toolbox

Added by Jonathan Moules over 6 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17412

Description

In the Processing toolbox (2.0.1), there is a "Geoalgorithms" which has a cog symbol.
There's also model - model symbol. And Script - script symbol.
However, when I go into either model or script, the items all have the "cog" symbol. Shouldn't they be respectively model and script symbols as applicable?
It's minor, but the discrepancy is incongruous.


p.s. In the "Category" section of this tracker, there's a blank between "Rasters" and "StyleV2" which I suspect used to be SEXTANTE.

History

#1 Updated by Alexander Bruy over 6 years ago

  • Status changed from Open to Rejected
  • Resolution set to worksforme

Works fine in master.

#2 Updated by Victor Olaya over 6 years ago

  • Status changed from Rejected to In Progress

Reopening it. Actually I had noticed that sometime ago, but I didn't fill an issue report

Alex, maybe a problem or resources?

#3 Updated by Jonathan Moules over 6 years ago

Just looked into it further - it's not a problem in the "Advanced interface" (not seen that before) - I guess that's what Alexander is using?

This issue happens in the "Simple interface" for me.

#4 Updated by Jonathan Moules over 6 years ago

Relatedly - "GDAL" -> "Analysis" -> fillnodata has no icon at all. The others seems fine.

#5 Updated by Alexander Bruy over 6 years ago

  • Resolution deleted (worksforme)

Jonathan Moules wrote:

This issue happens in the "Simple interface" for me.

This is your fault then :-), you have to specify this in first post.

I can confirm this with simplified interface.

Please, post tickets in Processing bugtracker, not in QGIS one. It is hard to track tickets in both redmine instances simultaneously

#6 Updated by Alexander Bruy over 6 years ago

Jonathan Moules wrote:

Relatedly - "GDAL" -> "Analysis" -> fillnodata has no icon at all. The others seems fine.

Please don't mix up different issues in one ticket and search in bugtracker before posting. This issue (with icon) already reported, see #7200

#7 Updated by Jonathan Moules over 6 years ago

Alexander Bruy wrote:

Please, post tickets in Processing bugtracker, not in QGIS one. It is hard to track tickets in both redmine instances simultaneously

I didn't know there was a processing bugtracker. There is a category for processing (SEXTANTE) on these ones which seemed the logical place to report it. The problem with lots of trackers is, it because a pain for the reporter - there's one for QGIS, one for the website (on github) and now one for the processing thing too.

Please don't mix up different issues in one ticket and search in bugtracker before posting. This issue (with icon) already reported, see #7200

Sorry about that, it seemed like it might be related/the same thing.

#8 Updated by Alexander Bruy over 5 years ago

  • Status changed from In Progress to Closed
  • Resolution set to fixed/implemented

Fixed in master

#9 Updated by Giovanni Manghi almost 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF