Bug report #8553

Diagrams: Automated placement settings are not saved or loaded in the project file

Added by Andreas Neumann about 6 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:17303

Description

Steps to reproduce:

1.
Set "automated placement settings" (Diagrams --> Position tab --> Automated Placement Settings) - e.g. checkbox "Show all labels and features for all layers ..."

2.
Save project

3.
Load project

Result: setting that was saved before is gone. Either it is not saved or not loaded from the project correctly.

History

#1 Updated by Matthias Kuhn about 6 years ago

  • Category changed from Symbology to Labelling

There is a (rather unintuitive) checkbox "save settings to project" at the bottom.

IMO this could be totally removed, or at least positioned more prominently.

#2 Updated by Matthias Kuhn about 6 years ago

  • Priority changed from Severe/Regression to Normal
  • Assignee deleted (Matthias Kuhn)

#3 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#4 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

Is this still an issue?

#5 Updated by Andreas Neumann over 4 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

All seems to be fine in current master. We can close this issue.

Thanks,
Andreas

Also available in: Atom PDF