Bug report #8524

Raster tiling offset in composer output from zoomed in resampling

Added by John Tull about 6 years ago. Updated 7 months ago.

Status:Closed
Priority:Normal
Assignee:Marco Hugentobler
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:end of life
Crashes QGIS or corrupts data:No Copied to github as #:17280

Description

The composer is creating raster artifacts that appear to be from some form of tiling in both pdf and png outputs. See the attached sample image that shows the non-alignment in raster layer output. It appears to be a shift in the raster "tiles".

raster_tiling_composer.png (165 KB) John Tull, 2013-08-28 11:10 AM

composer_resampling_bug.tiff - composer preview window (2.63 MB) John Tull, 2013-08-28 02:13 PM

Raster_artifact_test.qgs - QGIS project file (7.65 KB) Oliver Story, 2016-03-05 08:49 PM

Raster_artifact_demo.png - Screenshot showing raster artifact in print composer (466 KB) Oliver Story, 2016-03-05 08:49 PM

History

#1 Updated by John Tull about 6 years ago

I repeated printing without the affected layer (sans heat map tif layer), and the tiling offset does not occur. I cannot think of anything unique about this layer that would make it do this, except perhaps image resampling. Indeed, switching the "zoomed in" resampling from "bilinear" to "nearest neighbour" produced an output without the tiling offset. Unfortunately, the image quality is not what I was hoping for. I tried "cubic", and it also suffers from the tiling offset problem.

In short, it appears that the zoomed in resampling for either bilinear or cubic is causing problems in the composer. This problem is not visible in the map canvas or in the composer preview, only in the output.

#2 Updated by John Tull about 6 years ago

  • Subject changed from Raster tiling in composer output to Raster tiling offset in composer output from zoomed in resampling

#3 Updated by John Tull about 6 years ago

I stand corrected. The offset is not visible in the main map canvas, but it does show up in the composer preview in addition to the output. I had to zoom in enough and update my preview, but the offset can be seen in the composer window.

#5 Updated by Paolo Cavallini over 5 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#6 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Feedback

Is this still an issue in current master? If so, please attach a test project and data set which demonstrates the issue.

#7 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

closing for lack of feedback, please reopen if necessary.

#8 Updated by Oliver Story over 3 years ago

This is still an issue for me in QGIS 2.12.3

I've uploaded a test project and a screenshot; raster available from https://www.dropbox.com/s/li7uxhribg89b3m/hillshade.zip?dl=0 as it's 7MB and I couldn't upload it.

For me the issue occurs with bilinear or cubic resampling, in print composer window and when exported as image or PDF (probably when exported as SVG too but I haven't tried this).

#9 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#10 Updated by Giovanni Manghi 7 months ago

  • Status changed from Reopened to Closed
  • Resolution changed from worksforme to end of life

Also available in: Atom PDF