Bug report #8493

"Save as Image" defaults to archaic media type

Added by Aren Cambre about 6 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17257

Description

If I do File > Save as Image, the default is BMP, an archaic media type that generally should only be used when modern alternatives don't work.

Could PNG be the default instead? For a general purpose raster image intended for non-GIS software (e.g., image editing, documents, printing, etc.), PNG seems like the best option. PNG is an open standard and, except where compression is needed, is generally the standard general purpose raster image type for modern applications.

Associated revisions

Revision 1e936df8
Added by Michael Kirk almost 5 years ago

Saving map defaults to PNG instead of BMP

This only affects a user the first time they save a map as an image.
Afterwards their preference is saved.

FIXES: #8493

Revision 6dd42cae
Added by Nathan Woodrow almost 5 years ago

Merge pull request #1864 from michaelkirk/feature/export-png-first-8493

[fixes #8493] "Save as Image" defaults to PNG

History

#1 Updated by Andreas Neumann about 6 years ago

+1 this bothered me since years. Not a big deal - only annoying. BMP is really the worst choice.

#2 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#3 Updated by Filipe Dias almost 6 years ago

  • Status changed from Open to Closed

In Menu ->File -> Save image .PNG is now the default.

#4 Updated by Richard Duivenvoorde almost 6 years ago

  • Status changed from Closed to Reopened

Hi Filipe from what did you conclude that .PNG is now the default?

From a fresh rebuild from now, in
Menu -> Project -> Save as Image is still defaulting to .bmp with me

Did you fix this yourself? Are we looking at the same things?

Reopening for now

#5 Updated by Etienne Tourigny almost 6 years ago

output format is saved in the lastSaveAsImageFilter user pref so default value has no effect once you select another one. But the default is still BW.

#6 Updated by Filipe Dias almost 6 years ago

Yes, I always use .PNG so Etienne's right. Sorry for closing the ticket.

#7 Updated by Nathan Woodrow almost 6 years ago

  • Tag set to easy

#8 Updated by Nathan Woodrow almost 5 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF