Bug report #8467

(OsX) Raster>Projection>Warp dies after one run

Added by Lene Fischer over 7 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GDAL Tools
Affected QGIS version:master Regression?:No
Operating System:OsX Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:17235

Description

An excercize with a warp and mask from a vector. Works fine a first run, but second time recieve ar errormessage.

Attached errormessage.

The same error at 4 Mac - everythin OK at 20 PC.

Screen_Shot_2013-08-14_at_11.40.39_AM.png (654 KB) Lene Fischer, 2013-08-14 07:53 AM

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Category changed from Rasters to GDAL Tools
  • Status changed from Open to Feedback
  • Operating System changed from MAC to OsX

The second run is with the same mask layer? Without closing first the tool dialog?

#2 Updated by Lene Fischer over 7 years ago

The second run is on another target file but the same mask. The dialoge is closed. Even if the computer is restarted it doesnet work any longer. No able to perform a warp.

#3 Updated by Giovanni Manghi over 7 years ago

  • Subject changed from Raster>Projection>Warp dies after one run to (OsX) Raster>Projection>Warp dies after one run

Lene Fischer wrote:

Even if the computer is restarted it doesnet work any longer. No able to perform a warp.

That's odd.

#4 Updated by Larry Shaffer about 7 years ago

Hi,

I can not reproduce this with latest master on Mac OS X 10.7.5. Recently, the handling of QPyNullVariant return values has been updated. This may have fixed your issue.

Please test with latest nightly build to verify. Thanks.

#5 Updated by rcline - almost 7 years ago

This is a bug that seems to occur frequently on new installs. The problem appears to occur with all of the GDAL raster file dialogs. The problem is in /Applications/QGIS.app/Contents/Resources/python/plugins/GdalTools/tools/GdalTools_utils.py

at line 362.

if selectedFilter != None:
dialog.selectNameFilter(selectedFilter)

In QGIS 2.0.1 the code tests if selectedFilter is a Python None. However, testing shows that it is either the filter name or NULL of type QPyNullVariant. This is a hard bug to trace because once it works, selectedFilter is never a NULL.

Changing the code to:
if selectedFilter != None and selectedFilter != NULL:
dialog.selectNameFilter(selectedFilter)

fixes the problem. Not sure if None can ever occur. Somebody that is familiar with the code needs to determine whether selectedFilter should be None or Null. There is a similar test at line 370 that I assumes also needs to be fixed. The problem persists into trunk.

#6 Updated by Giovanni Manghi almost 7 years ago

  • Pull Request or Patch supplied changed from No to Yes

rcline - wrote:

This is a bug that seems to occur frequently on new installs. The problem appears to occur with all of the GDAL raster file dialogs. The problem is in /Applications/QGIS.app/Contents/Resources/python/plugins/GdalTools/tools/GdalTools_utils.py

at line 362.

if selectedFilter != None:
dialog.selectNameFilter(selectedFilter)

In QGIS 2.0.1 the code tests if selectedFilter is a Python None. However, testing shows that it is either the filter name or NULL of type QPyNullVariant. This is a hard bug to trace because once it works, selectedFilter is never a NULL.

Changing the code to:
if selectedFilter != None and selectedFilter != NULL:
dialog.selectNameFilter(selectedFilter)

fixes the problem.

better submit a patch on github.

#7 Updated by Giovanni Manghi about 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

tested yesterday on a fresh qgis 2.4 install on a brand new mac and it works ok. Please reopen if necessary.

Also available in: Atom PDF