Bug report #8398

Help doesn't open

Added by Jonathan Moules about 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17170

Description

This seems like quite a critical issue.

Pressing any of the "help" buttons doesn't open any help. I get a log message though:
Error starting help viewer[0] - level 1.

Windows weekly build - a13cdf8

Associated revisions

Revision 58b79108
Added by Jürgen Fischer almost 7 years ago

osgeo4w: fix install in directory with blanks (fixes #8398)

History

#1 Updated by Matthias Kuhn about 7 years ago

  • Priority changed from Normal to Severe/Regression

If this is confirmed, it's a blocker

#2 Updated by Salvatore Larosa about 7 years ago

  • Status changed from Open to Feedback

Not confirmed here, I also tested it on Windows XP (e3b8b41) and it works.

#3 Updated by Jonathan Moules about 7 years ago

I'm using Windows 7, 64bit. It's a new install on a new machine that hasn't had QGIS installed on it before.

#4 Updated by Regis Haubourg about 7 years ago

not reproduced here, windows 7 64 bit.
but I get a error message in qgis.org site, the url seems deprecated.

#5 Updated by Jonathan Moules about 7 years ago

Does it require internet access to work? My QGIS doesn't have internet access.

#6 Updated by Giovanni Manghi about 7 years ago

Jonathan Moules wrote:

Does it require internet access to work? My QGIS doesn't have internet access.

"help content" (shortcut f1) opens a web page, in a browser.

#7 Updated by Nathan Woodrow about 7 years ago

I can't confirm here too. Opens http://docs.qgis.org/2.0/html/en/docs/user_manual/ for me.

#8 Updated by Jonathan Moules about 7 years ago

Giovanni Manghi wrote:

Jonathan Moules wrote:

Does it require internet access to work? My QGIS doesn't have internet access.

"help content" (shortcut f1) opens a web page, in a browser.

Yep, that works for me, but it's not the error I'm reporting.

The failure is the dialog specific help buttons. So "Add Oracle Tables" -> Help fails. "Add Layers from a Server" (WMS/WMTS) - Help fails. Every one of them that I've tried fails.

#9 Updated by Giovanni Manghi about 7 years ago

The failure is the dialog specific help buttons. So "Add Oracle Tables" -> Help fails. "Add Layers from a Server" (WMS/WMTS) - Help fails. Every one of them that I've tried fails.

they all work fine here, on both Linux and Windows.

#10 Updated by Rémi Bovard about 7 years ago

Confirmed here

Error starting help viewer [0]

On weekly a13cdf8 - Win7 32 bits

#11 Updated by Salvatore Larosa about 7 years ago

Please, could you try with a more updated weekly package or better, if possible, with the latest master ?

#12 Updated by Rémi Bovard about 7 years ago

Always the same error with the latest weekly 7748102

#13 Updated by Nathan Woodrow about 7 years ago

Can't confirm here. Opens the help viewer as expected.

#14 Updated by Nathan Woodrow almost 7 years ago

Can we get an update on this Jonathan using the latest master.

#15 Updated by Jonathan Moules almost 7 years ago

I can't install the master, only the weeklies. I guess I can do that tomorrow as it hasn't been built yet.

#16 Updated by Salvatore Larosa almost 7 years ago

Jonathan Moules wrote:

I can't install the master, only the weeklies. I guess I can do that tomorrow as it hasn't been built yet.

Could you try to rename path/to/application/QGIS Weekly to path/to/application/QGIS_Weekly ?
or at least to strip the spaces into your app path ? This trick has worked for me although it is very strange !
wainting for the fix, you can choose an own path without spaces when you install the weekly package!

Also, I am not sure whether using escaped quotes would solve the problem:

diff --git a/src/core/qgscontexthelp.cpp b/src/core/qgscontexthelp.cpp
index b259032..3a743c5 100644
--- a/src/core/qgscontexthelp.cpp
+++ b/src/core/qgscontexthelp.cpp
@@ -73,7 +73,7 @@ QProcess *QgsContextHelp::start()
   }
 #endif

-  process->start( helpPath );
+  process->start( "\\"" + helpPath + "\\"" );

   return process;
 }

#17 Updated by Rémi Bovard almost 7 years ago

It worked !

I installed latest weekly in C:\\Temp\\QGIS_Weekly

#18 Updated by Jonathan Moules almost 7 years ago

It seems like in a bout of stupidity, our corporate network has now blocked the download of .exe files so I can't even download the new QGIS weekly. sigh

However I can confirm using the a13cdf8 that renaming to "QGIS_Weekly" from "QGIS Weekly" does resolve the issue.

#19 Updated by Andreas Neumann almost 7 years ago

Works fine for me. However, some of the help content is very outdated. E.g. the help for layer properties talks about 7 tabs, but there are 10 and it is really completely outdated.

Wasn't the idea that we jump directly to the corresponding section in the online help?

#20 Updated by Jürgen Fischer almost 7 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF