Bug report #8311

Layer display choice should default to "Field", not "HTML"

Added by Nyall Dawson over 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17104

Description

Currently the "Display" choice for vector layers defaults to "HTML" (which is by default blank). This causes issues when using the identify tool on multiple objects, since the tree parent for each identified feature is blank (see attached screenshot).

I'd suggest defaulting to the "Field" choice for "Display", since this gives a value for the parent for each feature (see second screenshot).

display_html_default.png - Current default of "HTML" display (19.2 KB) Nyall Dawson, 2013-07-16 03:45 PM

display_field.png - Suggested default of "Field" display (15.8 KB) Nyall Dawson, 2013-07-16 03:45 PM

Associated revisions

Revision 43caf02d
Added by Nyall Dawson about 7 years ago

Make sure updateFields() is called before setDisplayField for new vector layers (fix #8311)

Revision 88d3adea
Added by Nathan Woodrow about 7 years ago

Merge pull request #804 from nyalldawson/bug_8311

Fix some bugs relating to display fields for new vector layers (fixes #8311)

History

#1 Updated by Nathan Woodrow about 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF