Bug report #8277

Non-positional str.format() arg specifiers break Console for Python 2.6

Added by Larry Shaffer about 8 years ago. Updated about 8 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Salvatore Larosa
Category:PyQGIS Console
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17080

Description

Running QGIS with Python 2.6, PyQGIS console throws errors because no positional arg specifier is used for str.format():

'Untitled-{}'.format(nr)  # causes error
'Untitled-{0}'.format(nr)  # OK for Python 2.6

Attached is quick search of console directory outputted to build directory (using simple '{}.+\\.format' grep).

str-format-errors.txt Magnifier (1.63 KB) Larry Shaffer, 2013-07-11 08:41 PM

Associated revisions

Revision 272400e3
Added by Nathan Woodrow about 8 years ago

Use positional for str.format(). Fix #8277

History

#1 Updated by Anonymous about 8 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF