Bug report #8052

QGIS 2.0 does not respect labels' scale-based visibility option when opening projects from previous version

Added by Duarte Carreira over 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:High
Assignee:Larry Shaffer
Category:Project Loading/Saving
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16893

Description

The min/max scales are set but disabled because the checkbox is turned off.

It is a migration issue of old projects. Even 1.9 projects from before the vector-branch merge are affected.

History

#1 Updated by Larry Shaffer over 6 years ago

  • Priority changed from Normal to High
  • Subject changed from qgis 2.0 does not respect labels' scale-based visibility option when opening existing 1.9 projects to QGIS 2.0 does not respect labels' scale-based visibility option when opening projects from previous version
  • Assignee set to Larry Shaffer

Hi Duarte,

This is a known effect after recent changes to new labeling to support expressions (mailing list posts).

It should function correctly when opening a valid QGIS 1.8 project, i.e. the Scale visibility checkbox should be checked and data defined values should work if either are set as before. However, I noticed that I missed adding that support and will do so shortly.

The support for migrating existing 1.9 projects to 2.0 will probably not be added (see Tim's comment in noted mailing list thread). This is also because it requires extraneous code to support the 1.9->2.0 update than just the 1.8->2.0 update. This was the case when updating the Buffer settings, but with Scale visibility I may be able to support 1.9->2.0 updating if it is simple and non-extraneous to do so.

#2 Updated by Duarte Carreira over 6 years ago

Hi Larry.

I wasn't aware of issues going from 1.9 to 2.0. I assumed that they were the same version and 2.0 was a completed 1.9...

I'll wait for 2.0 and evaluate the needed effort... and cross my fingers only small adjustments are needed.

Thanks for your work on this!

#3 Updated by Larry Shaffer over 6 years ago

Should be fixed with commit d547b25

Please test. That commit also fixes another unreported bug where scales closer than 1:1, e.g. 5:1, could not be set.

New usage info from tool tip:
Value < 0 represents a scale closer than 1:1, e.g. -10 = 10:1.
Value of 0 toggles off specific limit.

#4 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#5 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

closing for lack of feedback, should be fixed.

Also available in: Atom PDF