Bug report #7988

Transparency not saved to styles. QGIS 1.9.0

Added by Eddy Barratt over 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16840

Description

I'm using 1.9.0 due to difficulties installing 1.8 on Ubuntu 13.04.

I have a style that is a singleband pseudocolor, and I decided I could do with the same style, but 50% transparent. So I used the transparency tap to make that so, and saved the style.

Now if I try to assign the new style by clicking on Load Style then the layer looks transparent, as I'd hope. But in the transparency tab transparency is apparently set at 0%. If I click OK or Apply, then this 0% transparency is assigned to the raster.

The only way to ensure that the correct style is applied is to 'Load Style' with the transparent style, and then click Cancel. A somewhat counter intuitive work around (and not ideal, I tend to use the Multi QML plugin to assign styles to multiple layers, this fails with transparent styles, I assume for similar reasons).

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

Confirmed. This used to work on qgis 1.8 ?

#2 Updated by Larry Shaffer over 7 years ago

  • Assignee set to Jürgen Fischer

The layer transparency style support was apparently removed (or stubbed) with commit 6b2af9a

Not sure why or if that commit is the reason for the issue, so I assigned Jürgen to the ticket.

#3 Updated by Jürgen Fischer over 7 years ago

  • Assignee deleted (Jürgen Fischer)

The layer transparency wasn't used anymore - I just removed all the getters/setters.

#4 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

this has been fixed recently in master.

Also available in: Atom PDF