Bug report #7977

Edit expression button looks silly

Added by Aren Cambre over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System:Windows 7 x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:16834

Description

In the Layer labeling settings dialog, there is text Label this layer with, then a dropdown, then a button with a lowercase Greek epsilon and an ellipsis (...). Please remove the epsilon. It makes the button look overdone, and ... alone is sufficient as it is well-understood to mean that there are more options for the adjacent feature.

expression_ls.png (861 Bytes) Larry Shaffer, 2013-06-03 10:29 AM

History

#1 Updated by Nathan Woodrow over 6 years ago

I would rather it say Expression and also have the icon. The Greek epsilon is being used though the UI to mean expression so it is there for consistency reasons. The ... alone is not enough as it doesn't tell the user what that button is for (trouble I have had in the past with students in training)

#2 Updated by Aren Cambre over 6 years ago

Sorry, didn't realize the epsilon is being used in other places in QGIS. I think I agree that epsilon + Expression is better here.

#3 Updated by Larry Shaffer over 6 years ago

Sorry, I have to disagree. First off, the issue is an opinion, not a bug, and better suited as a post to the mailing list.

IMO, the use of an icon works better, and is now the standard to represent an Expression. The HIG specifies putting an ellipses for actions that pop open a dialog, which is why the button is labeled 'E...'. Other parts of the GUI don't even go that far (see new attribute table).

Having just an ellipsis generally represents opening a file browsing dialog of some kind. That is clearly not the case here, so more is needed.

The button already has a tool tip that says 'Edit expression'. Also ALL of the new labeling data defined buttons use the epsilon symbol to represent when an expression is set. Users will learn that the epsilon represents expressions or expression functions, possibly after just one use. IMO, there should be no change, except maybe how the epsilon is styled.

Initially, I thought just an 'E' was not enough. I proposed an '(E)' instead, however, though it was accepted, for whatever reason it was not adopted.

#4 Updated by Nathan Woodrow about 6 years ago

  • Resolution set to wontfix

#5 Updated by Nathan Woodrow about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF