Bug report #7970

qgis crashes when creating new spatialite layer - changing crs

Added by Regis Haubourg over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Data Provider/SpatiaLite
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:16829

Description

Hi all,
when creating a new spatialite layer from menu layer/new layer /spatialite,
choosing a new crs (2154 epsg in my case), I have a crash.
a regression, then I put it to blocker priority.
Régis

conf: win 7 , osgeo4w , revision e2bd04f

Régis


Related issues

Related to QGIS Application - Bug report #8041: crs selector dialog broken in new spatialite layer window Closed 2013-06-11

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Category set to Data Provider/SpatiaLite
  • Priority changed from Normal to Severe/Regression
  • Target version set to Version 2.0.0

#2 Updated by Giovanni Manghi over 6 years ago

confirmed on Linux

[email protected] ~ $ qgis
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
Fatal: QGIS died on signal 11
Stacktrace (run through c++filt):
/usr/bin/qgis.bin(myMessageOutput(QtMsgType, char const*)+0xac)[0x4e6b5c]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(qt_message_output(QtMsgType, char const*)+0x2e)[0x7fdfbd25841e]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(+0x718bf)[0x7fdfbd2588bf]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(qFatal(char const*, ...)+0x94)[0x7fdfbd258a64]
/lib/x86_64-linux-gnu/libc.so.6(+0x364a0)[0x7fdfba7494a0]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QLocalePrivate::stringToLongLong(QString const&, int, bool*, QLocalePrivate::GroupSeparatorMode) const+0x6c)[0x7fdfbd28a98c]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QString::toLongLong(bool*, int) const+0x42)[0x7fdfbd2ab222]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QString::toInt(bool*, int) const+0x9)[0x7fdfbd2ab349]
/usr/bin/qgis.bin(QgsNewSpatialiteLayerDialog::on_pbnFindSRID_clicked()+0x8ab)[0x7a4c9b]
/usr/bin/qgis.bin[0x7c7e15]
/usr/bin/qgis.bin(QgsNewSpatialiteLayerDialog::qt_metacall(QMetaObject::Call, int, void**)+0x5b)[0x7c7f0b]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QMetaObject::activate(QObject*, QMetaObject const*, int, void**)+0x4b9)[0x7fdfbd376489]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QAbstractButton::clicked(bool)+0x32)[0x7fdfbcd74c72]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x599a4e)[0x7fdfbcab2a4e]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x59ad8b)[0x7fdfbcab3d8b]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QAbstractButton::mouseReleaseEvent(QMouseEvent*)+0x8c)[0x7fdfbcab3ffc]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QWidget::event(QEvent*)+0x684)[0x7fdfbc735144]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplicationPrivate::notify_helper(QObject*, QEvent*)+0xb4)[0x7fdfbc6e4894]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplication::notify(QObject*, QEvent*)+0xabf)[0x7fdfbc6ea0bf]
/usr/lib/libqgis_core.so.1.9.0(QgsApplication::notify(QObject*, QEvent*)+0x96)[0x7fdfbe26ec46]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QCoreApplication::notifyInternal(QObject*, QEvent*)+0x8c)[0x7fdfbd361e9c]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool)+0x172)[0x7fdfbc6e5862]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x24bbf5)[0x7fdfbc764bf5]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplication::x11ProcessEvent(_XEvent*)+0xdce)[0x7fdfbc763bae]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x2740d2)[0x7fdfbc78d0d2]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x133)[0x7fdfb9275d53]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x480a0)[0x7fdfb92760a0]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x34)[0x7fdfb9276164]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)+0x6f)[0x7fdfbd3913bf]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x273d5e)[0x7fdfbc78cd5e]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)+0x32)[0x7fdfbd360c82]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>)+0xf7)[0x7fdfbd360ed7]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QDialog::exec()+0xd6)[0x7fdfbcbb4936]
/usr/bin/qgis.bin(QgisApp::newSpatialiteLayer()+0x48)[0x4f2718]
/usr/bin/qgis.bin[0x7b9cd5]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QMetaObject::activate(QObject*, QMetaObject const*, int, void**)+0x2b1)[0x7fdfbd376281]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QAction::triggered(bool)+0x32)[0x7fdfbc6de132]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QAction::activate(QAction::ActionEvent)+0x6f)[0x7fdfbc6de31f]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x617119)[0x7fdfbcb30119]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x61d272)[0x7fdfbcb36272]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QWidget::event(QEvent*)+0x684)[0x7fdfbc735144]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QMenu::event(QEvent*)+0x5b)[0x7fdfbcb3780b]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplicationPrivate::notify_helper(QObject*, QEvent*)+0xb4)[0x7fdfbc6e4894]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplication::notify(QObject*, QEvent*)+0xabf)[0x7fdfbc6ea0bf]
/usr/lib/libqgis_core.so.1.9.0(QgsApplication::notify(QObject*, QEvent*)+0x96)[0x7fdfbe26ec46]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QCoreApplication::notifyInternal(QObject*, QEvent*)+0x8c)[0x7fdfbd361e9c]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool)+0x172)[0x7fdfbc6e5862]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x24c2c1)[0x7fdfbc7652c1]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplication::x11ProcessEvent(_XEvent*)+0xdce)[0x7fdfbc763bae]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x2740d2)[0x7fdfbc78d0d2]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x133)[0x7fdfb9275d53]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x480a0)[0x7fdfb92760a0]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x34)[0x7fdfb9276164]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)+0x6f)[0x7fdfbd3913bf]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x273d5e)[0x7fdfbc78cd5e]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)+0x32)[0x7fdfbd360c82]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>)+0xf7)[0x7fdfbd360ed7]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QCoreApplication::exec()+0x87)[0x7fdfbd365f67]
/usr/bin/qgis.bin(main+0x229e)[0x4e2b0e]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xed)[0x7fdfba73476d]
/usr/bin/qgis.bin[0x4e6901]
Aborted (core dumped)

#3 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Feedback

I just solved a likely related crash ( in 63617ba )
Can you check and mark this issue as "Closed" or "New" accordingly.

#4 Updated by Mathieu Pellerin - nIRV over 6 years ago

I've tried and can't reproduce crash. Regis, can you confirm it's been fixed and close the issue?

#5 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Feedback to Closed

Crash fixed.
Followup for remaining problem: #8041

#6 Updated by Regis Haubourg over 6 years ago

confirmed here, sorry for the delay, I wasn't at office.
régis

Also available in: Atom PDF