Bug report #7926

blending modes layer are not exported well if resolution is high

Added by Regis Haubourg about 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Vincent Mora
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:16797

Description

High,
when exporting a composer in raster mode (A0 or A1), when asking for higher dpi, layers with blending mode are not rendered.
I have a A1 composition , export is ok in up to 220 dpi. When asking 250 or higher, I loose those layers
With A0 same composition, the threshold is lower 50 dpi is KO.

See attached screenshot.

bug_blending_export.jpg (375 KB) Regis Haubourg, 2013-05-28 07:28 AM

Associated revisions

Revision eeaa867e
Added by Vincent Mora about 7 years ago

- fix #7926
- the painting is ended if image cannot be allocated in renderer

Revision 812d1ed1
Added by Nathan Woodrow about 7 years ago

Merge pull request #776 from Oslandia/issue7926

- fix #7926

History

#1 Updated by Mathieu Pellerin - nIRV about 7 years ago

Regis, this might be "fixed" by this bed65cb1f4dbc582d0b3be0d3b1d9e9083e8086e

The above introduces a warning message when running out of memory while exporting to image. Could you check and confirm?

#2 Updated by Paolo Cavallini about 7 years ago

  • Category set to 33

#3 Updated by Jürgen Fischer about 7 years ago

  • Status changed from Open to Feedback

#4 Updated by Nathan Woodrow about 7 years ago

Regis can we get a update on this if you are still having the same issue.

#5 Updated by Giovanni Manghi about 7 years ago

Nathan Woodrow wrote:

Regis can we get a update on this if you are still having the same issue.

isn't this another side of the printing memory issue on Windows? See for example #4821-24

#6 Updated by Hugo Mercier about 7 years ago

  • Assignee set to Hugo Mercier
  • Status changed from Feedback to In Progress

Reproduced on a Windows 32 bits. Can't reproduce on a Linux 64 bits.
Not sure yet if it is related to #4821
Seems related to a memory issue.

Working on it

#7 Updated by Vincent Mora about 7 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Hugo Mercier to Vincent Mora
  • Resolution set to fixed
  • Pull Request or Patch supplied changed from No to Yes

We found the problem with Hugo in QgsMapRenderer::render where an image could not be allocated (too big). The fix is here:

https://github.com/qgis/Quantum-GIS/pull/776

#8 Updated by Nathan Woodrow about 7 years ago

  • Status changed from Resolved to Closed

#9 Updated by Vincent Mora about 7 years ago

Bug fixed thanks to fundings from Agence de l'Eau Adour-Garonne.

Also available in: Atom PDF