Feature request #7870

Selecting underlying items in Composer.

Added by Thomas McAdam about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:-
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No

Description

In Composer it doesn't seem possible to select items that are directly beneath another item. A common use scenario is to place a rectangle, with no background over the entire map to create a border. This rectangle needs to be at the top of the draw order to make sure it isn't overwritten by other items in the map close to the edge. This renders everything in the map unselectable, without first eselecting the border rectangle, pushing it down the draw order, making the changes to the other object and then bringing it back up after. It would be useful to allow multiple mouse clicks, or using a shortcut key and mouse clicking, to 'scroll' through the selectable items stacked at a particular point.

History

#1 Updated by Nathan Woodrow about 4 years ago

  • Target version set to Future Release - High Priority
  • Assignee set to Nyall Dawson

Nyall is working on this.

#2 Updated by Nyall Dawson about 4 years ago

  • Resolution set to duplicate

Duplicate of #4358. A fix is coming shortly!

#3 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF