Bug report #7699

SVG fill missing default value for text width and border unit type

Added by Mathieu Pellerin - nIRV over 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16612

Description

SVG fill is missing default unit type value for the texture width and border width. This leads to the SVG fill silently using "map unit" as value, and it can be quite misleading give user unexpected / confusing results.

Steps to reproduce:
1. Open a new project and add a polygon layer (can be any provider, doesn't matter)
2. Open the layer properties window and go into the Style section
3. Change the symbol layer to SVG fill
4. Take a second to notice absence of default unit type

Symbology's default unit on all layer types is millimeter, it should be the same for SVG fill.

Associated revisions

Revision 639d4c41
Added by Nyall Dawson over 5 years ago

Fix missing default unit types for SVG fills (fix #7699)

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Priority changed from Normal to Severe/Regression

it seems it assumes map units, anyway certainly something to fix before 2.0 and a regression since 1.8.

#2 Updated by Mathieu Pellerin - nIRV over 6 years ago

  • Priority changed from Severe/Regression to High

Lowering priority to high as this shouldn't really be a blocker to a 2.0 release.

#3 Updated by Giovanni Manghi over 6 years ago

  • Priority changed from High to Normal

Mathieu Pellerin - nIRV wrote:

Lowering priority to high as this shouldn't really be a blocker to a 2.0 release.

it also does not causes crash, so tagging as normal.

#4 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#5 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF