Bug report #7512

print engine fouling up labels

Added by John Sankey almost 7 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:1.8.0 Regression?:No
Operating System:Mac OSX Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:16461

Description

As you can see from the attached images, top is the screen view, bottom the print output, the print engine is fouling up labels when there are more than just a few of them. I don't know yet when it starts doing this - this is about double the number of labels I was able to print successfully.

screen.jpg (81.4 KB) John Sankey, 2013-04-04 06:06 PM

print.jpg (80.6 KB) John Sankey, 2013-04-04 06:06 PM

mapa.jpg (70.1 KB) John Sankey, 2013-04-04 07:04 PM

History

#1 Updated by Larry Shaffer almost 7 years ago

Hi John,

You noted 1.8 for the version. Is that correct, or is this with master branch build (if so, which sha commit id)?

#2 Updated by John Sankey almost 7 years ago

1.8.0 is correct. I have to stick to stable releases because of the importance of my work with it.

#3 Updated by Larry Shaffer almost 7 years ago

Unfortunately I can't get either of your issue attachments to load in my browser (Redmine issue ??). Can you post links to them on a different server?

#4 Updated by John Sankey almost 7 years ago

Firefox gets them fine. I put them on my server: http://johnsankey.ca/qgis2.jpg is the screen view, ...qgis3.jpg the print output. Hope that works.

#5 Updated by Larry Shaffer almost 7 years ago

Sorry John, I can't load those either (regardless of browser used). Maybe they are corrupted somehow. I had no problem loading your site. All browsers just stall (as if waiting for the download to start) when trying to load them. Will check back later.

#6 Updated by John Sankey almost 7 years ago

An added note: all labels use the new labeller, with data-dependent x,y,rotation. That itself isn't the problem; see the attached for a successful print of the same data with fewer labels. (Online it's at http://hunt-club.ncf.ca/mapa.jpg for now)

#7 Updated by John Sankey almost 7 years ago

Two additional notes: I tried using the old label system for some, then all of the labels. Both ways, the print engine showed everything properly in the window, but went into an infinite loop when saving to image. I think it's triggered by labels too close to each other even though the old label system doesn't have conflict detection.

There might well be two issues here: 1. buffer management, since different results are obtained with different numbers of labels, and 2. inconsistencies in the label collision avoidance system. Anyone with a complex requirement needs the option of turning collision avoidance 100% off. The examples I give are a picnic compared to city zoning maps :-(

I've checked my images with everything here - they're standard jpegs with no EXIF or any other added code and show fine on everything an Apple has...

#8 Updated by Jürgen Fischer almost 6 years ago

  • Category set to Map Composer/Printing

#9 Updated by Nyall Dawson almost 6 years ago

  • Category changed from Map Composer/Printing to Labelling

#10 Updated by Nyall Dawson almost 4 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

Closing due to age of bug. If it's still an issue in current versions please open a new report with a sample project

Also available in: Atom PDF