Bug report #7134

new labels are not saved in qml as they were old labels

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Larry Shaffer
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16201

Description

With old labels/symbology the labels were saved with other symbology stuff inside th qml style file. The new labels are not.

Unless this is by design this is a regression.


Related issues

Duplicates QGIS Application - Feature request #3300: new labeling should be saved in the qml file Closed

Associated revisions

Revision 87ca653e
Added by Nathan Woodrow over 6 years ago

Fix #7134

History

#1 Updated by John Tull over 6 years ago

And the inverse is true as well. I.e., loading a qml file with labeling definitions fails to change the labeling options in the layer.

#2 Updated by Nathan Woodrow over 6 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Seems to be fine in master now. Reopen if not fixed for you.

#3 Updated by Giovanni Manghi over 6 years ago

  • Resolution deleted (worksforme)
  • Status changed from Closed to Reopened

I just updated on osgeo4w and still does not work. When you apply the .qml style the labels does not show and in fact the "label this layer with" checkbox is not even active.

The fix had been applied after the latest qgis revision available now on osgeo4w? if yes you can close (again) this ticket. Cheers!

#4 Updated by Nathan Woodrow over 6 years ago

Ok yes it seems the loading is the issue.

#5 Updated by Nathan Woodrow over 6 years ago

  • Assignee set to Nathan Woodrow

#6 Updated by Nathan Woodrow over 6 years ago

Fix in progress.

#7 Updated by Nathan Woodrow over 6 years ago

  • Assignee changed from Nathan Woodrow to Larry Shaffer

Larry is taking a look now.

#8 Updated by Anonymous over 6 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF