Bug report #7095

Invalid error when using WFS versions >= 1.0.0

Added by Jonathan Moules almost 9 years ago. Updated almost 9 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16176

Description

Following #6921

With master I get a different bug.

Using either:
http://wppgeog3:8082/geoserver/wfs?version=1.1.0
or
http://wppgeog3:8082/geoserver/wfs?version=1.3.0

The following happens.

When I click connect I get this error:
"The WFS server does not support WFS version 1.0".

There are several problems here:
- The WFS server /does/ support all three versions of WFS (its GeoServer)
- There is no "WFS 1.0". There is a WFS 1.0.0, 1.1.0 and 1.3.0
- I've just requested WFS 1.1.0 or 1.3.0. Not 1.0.0

This doesn't happen if I use:
http://wppgeog3:8082/geoserver/wfs?version=1.0.0

I appreciate QGIS probably doesn't support them, but the error should be correct.

History

#1 Updated by Marco Hugentobler almost 9 years ago

  • Status changed from Open to Closed

Changed in 2c980d2596e9d9c520b70265438d879348d2f47a

Also available in: Atom PDF