Bug report #6990

pyspatialite: some spatialite functions not recognised

Added by Laurent Gasnier almost 8 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16094

Description

In DBManager, some spatialite functions known in V3.0.1 throw a database error "no such function".
Examples: ST_OffsetCurve, ST_Line_Interpolate_Point
SQL query used in SQL window:
SELECT PK_UID, textstring, ST_OffsetCurve(Geometry, 1000 , 0) as geom from Anno_T6;
SELECT PK_UID, textstring, ST_Line_Interpolate_Point(Geometry, 0.5) as geom from Anno_T6;

History

#1 Updated by Giovanni Manghi almost 8 years ago

  • Status changed from Open to Feedback

on qgis master, right?

#2 Updated by Giovanni Manghi almost 8 years ago

and on what OS?

#3 Updated by Laurent Gasnier almost 8 years ago

On qgis master and OS windows 7.

#4 Updated by Regis Haubourg almost 8 years ago

Confimed here with Qspatialite too. A provider issue?
Everything works ok in spatialite_gui_v4

#5 Updated by Jürgen Fischer almost 8 years ago

  • Status changed from Feedback to Open

#6 Updated by Giuseppe Sucameli over 7 years ago

It depends on pyspatialite module.

#7 Updated by Giuseppe Sucameli over 7 years ago

  • Category deleted (DB Manager)
  • Operating System set to Windows

#8 Updated by Giuseppe Sucameli over 7 years ago

  • Subject changed from DBManager : some spatialite functions not recognised to pyspatialite: some spatialite functions not recognised

#9 Updated by Paolo Cavallini over 7 years ago

Shouldn't this be moved upstream, on the pyspatialite bugtracker?

#10 Updated by Laurent Gasnier over 7 years ago

Is there a particular need of pyspatialite ?
For other GIS works on W7, I use pysqlite with Spatialite DDLs without such problems.
See https://groups.google.com/forum/?fromgroups=#!topic/spatialite-users/VawtWeN5t2Q
But I tested it only on W7...

#11 Updated by Paolo Cavallini over 7 years ago

  • Priority changed from High to Normal

Please move this to the relevant library; if necessary, open a new ticket about the rest

#12 Updated by Médéric RIBREUX almost 5 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

it seems to be fixed in QGIS 2.13 master (and probably in earlier releases) because I can use ST_Line_Interpolate_Point and St_Offsetcurve in DBManager.
Can you confirm ?

#13 Updated by Laurent Gasnier almost 5 years ago

Yes, I confirm. These functions work on QGis 2.12. This issue can be closed.
Thanks.

#14 Updated by Médéric RIBREUX almost 5 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Ok, I am closing this bug because it is fixed in QGIS 2.13 and 2.12!

Also available in: Atom PDF