Bug report #6968

Saving selects wrong tool

Added by Nathan Woodrow over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Larry Shaffer
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16078

Description

If you save a layer the tool is reverted back to the last used non edit based tool - select, pan, info, etc

To reproduce:

  1. Create a new layer
  2. Select Zoom Tool
  3. Enable editing for the layer
  4. Select Add Feature tool.
  5. Add new feature
  6. Click save

After saving the Add Feature tool is no longer selected but instead the Zoom Tool is.

save-rollback_deselect-tool_patch.diff Magnifier (3.03 KB) Larry Shaffer, 2013-01-10 02:00 AM

Associated revisions

Revision 8803a00a
Added by Larry Shaffer over 6 years ago

Fix #6968, saving/rollbacking edits deselects current editing tool

Revision a3f5cea2
Added by Larry Shaffer over 6 years ago

Merge pull request #382 from dakcarto/iface_edits-tool-switch-fix_1

Fix #6968, saving/rollbacking edits deselects current editing tool

History

#1 Updated by Nathan Woodrow over 6 years ago

Larry I have assigned due to your recent save improvements. If this is unrelated you can remove yourself.

Blocker as it is a regression.

#2 Updated by Larry Shaffer over 6 years ago

Hi Nathan,

I think it is unrelated, but will check to make sure. If it's something I coded for saving edits, then I have an idea on what might be causing it.

Does the same happen when you use any of the Current Edits functions (instead of the single-click Save Layer Edits button)?

#3 Updated by Nathan Woodrow over 6 years ago

Yeah it happens with any saving, rollback functions.

This method might be what is causing it: https://github.com/qgis/Quantum-GIS/blob/master/src/app/qgisapp.cpp#L7291

#4 Updated by Larry Shaffer over 6 years ago

Yes, that's what I was thinking. It is called at the end of each of the new editing methods. Looks like it needs a different approach. Will look into this ASAP.

#5 Updated by Larry Shaffer over 6 years ago

Hi Nathan,

See if https://github.com/qgis/Quantum-GIS/pull/382 fixes it for you. Also attached as a patch.

#6 Updated by Larry Shaffer over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF