Bug report #6904

Move several C++ plugins into core

Added by Nathan Woodrow over 7 years ago. Updated over 3 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:C++ Plugins
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16029

Description

There really isn't any reason that we can't have the heatmap plugin code as part of core QGIS rather then just a core plugin. If it is moved to core QGIS we can give it a API so that people other people can use it.

History

#1 Updated by Paolo Cavallini over 7 years ago

  • Subject changed from Move heatmap plugin into core to Move several C++ plugins into core

This applies also to many (most?) other C++ plugins.

#2 Updated by Giovanni Manghi over 7 years ago

Paolo Cavallini wrote:

This applies also to many (most?) other C++ plugins.

this was a suggestion I made a while ago on the dev mailing list (users do ask me, why is a plugin if it comes with qgis?) and it was rejected.

#3 Updated by Nathan Woodrow over 7 years ago

Giovanni Manghi wrote:

Paolo Cavallini wrote:

This applies also to many (most?) other C++ plugins.

this was a suggestion I made a while ago on the dev mailing list (users do ask me, why is a plugin if it comes with qgis?) and it was rejected.

Why was it rejected?

#4 Updated by Giovanni Manghi over 7 years ago

Why was it rejected?

don't remember exactly the reasons... it was Martin who gave the reason.

#5 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Jürgen Fischer about 4 years ago

  • Assignee deleted (Arunmozhi P)

#7 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • road graph
  • interpolation
  • terrain analysis
  • zonalstatistics
  • heatmap

are now in the QGIS analysis library.

Also available in: Atom PDF