Bug report #6845

Zoom in/out area on master looks as a solid grey rectangle

Added by Giovanni Manghi almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Marco Hugentobler
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15981

Description

it happens on master/windows.

when you zoom in/out by dragging the mouse the area is no more a translucent rectangle but a solid grey one.

See attached image.

grey.png (201 KB) Giovanni Manghi, 2012-12-09 03:54 AM

Capture.PNG (450 KB) Giovanni Manghi, 2012-12-16 04:58 PM

grass_region.png (183 KB) Giovanni Manghi, 2012-12-16 04:58 PM

History

#1 Updated by Salvatore Larosa almost 7 years ago

same here on Linux (see image: http://lrssvt.ns0.it/img/zoom_rect.png)

#2 Updated by Salvatore Larosa almost 7 years ago

I think it is due to b777b51147e7b9ea0d89d480273d4d8240c9b594

tools select, measure etc are also affected !

#3 Updated by Giovanni Manghi almost 7 years ago

  • Assignee set to Marco Hugentobler

Salvatore Larosa wrote:

I think it is due to b777b51147e7b9ea0d89d480273d4d8240c9b594

tools select, measure etc are also affected !

#4 Updated by Larry Shaffer almost 7 years ago

Can not replicate on Mac. The marquee on mouse drag is still transparent here.

#5 Updated by Salvatore Larosa almost 7 years ago

Hi Larry,
could you test Measure Line tool too ? or Select Features by Rectangle ?

In the video what happen to me!

http://lrssvt.ns0.it/img/rubberBand.ogv

#6 Updated by Larry Shaffer almost 7 years ago

Hi Salvatore,

Same thing, no issues. Not seeing the greyed-out fill like in your video.

The Measure Line dialog now gets sent to behind main window (in window stacking order) on measure tool's second click, but that's a different bug.

#7 Updated by Werner Macho almost 7 years ago

confirmed here on LinuxMint with fresh master (11.Dec.2012)
Strange behavior detected:
measuring tool (angle): it is dependant if is start top-down (nothing happens) or bottom-up (every 2-3 try the screen gets completely grey)
measuring tool (line): I cannot see any line drawn any more. Line is not visible (if there is any)
Zoom: in or out - always getting a grey rectangle like in the png from Salvatore
Select Feature (rectangle): Also getting grey rectangle but not every time .. sometimes it is transparent again.. and sometimes it is transparent with a thick grey border .. unfortunately the amount of tries to get it transparent is unpredictable and therefore not reproduceable
Also selecting by polygon, freehand or radius is producing a non transparent grey rectangle.

#8 Updated by Nathan Woodrow almost 7 years ago

Confirmed here on XP with master at version afde353

#10 Updated by Matthias Kuhn almost 7 years ago

  • Status changed from Open to Closed

fixed in d997863

#11 Updated by Giovanni Manghi almost 7 years ago

There is still something wrong with the GRASS region frame (and area, when manually defining a region).

See attached images.

Also the grass region frame does not show as used to be.

#12 Updated by Giovanni Manghi almost 7 years ago

  • Status changed from Reopened to Closed

I will file another ticket about the GRASS region issue.

#13 Updated by Giovanni Manghi almost 7 years ago

  • Resolution set to fixed

Also available in: Atom PDF