Bug report #6383

Map overview broken

Added by Paolo Cavallini about 8 years ago. Updated over 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:GUI
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15642

Description

Map overview seems broken (tested on 15 machines, various OSs, about half not working). I suspect this has been opened already, but cannot find it.

History

#1 Updated by Mathieu Pellerin - nIRV about 8 years ago

For a couple of weeks now, click on the [ ] show in overview right-click menu item fails to update overview with the specified layer unless you deactivate and reactivate the layer. Is this what you're referring to?

#2 Updated by Paolo Cavallini about 8 years ago

  • Affected QGIS version changed from master to 1.8.0

Not really: just adding a map to an overview fails to show any map in about half of the cases

#3 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

is the overview map fixed? it works here on master!

#4 Updated by Nyall Dawson over 7 years ago

I've noticed one issue with the overview map in Master - if a map item is set to 'rectangle' mode then overview frames are not shown when the composer is exported. Could this explain what you were experiencing Paolo?

#5 Updated by Giovanni Manghi over 7 years ago

Nyall Dawson wrote:

I've noticed one issue with the overview map in Master - if a map item is set to 'rectangle' mode then overview frames are not shown when the composer is exported. Could this explain what you were experiencing Paolo?

I don't think the issue is this. Paolo is referring to the overview is available in the QGIS main window (right click a layer -> add to overview).

#6 Updated by Paolo Cavallini over 7 years ago

Exactly. It seems to work on current master in Debian though. Must be checked on Win.

#7 Updated by Regis Haubourg over 7 years ago

Hi, not reproduced in osgeo4w master 5e29777..

#8 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Also available in: Atom PDF