Bug report #6273

Remove item in Style manager only deletes single item

Added by Nathan Woodrow about 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:Arunmozhi P
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15576

Description

If you select more then one symbol in the style manager the remove item button (-) doesn't remove the selected items, only removes a single item.

6273.patch Magnifier (1.61 KB) Arunmozhi P, 2012-09-16 06:13 AM

History

#1 Updated by Giovanni Manghi about 7 years ago

  • Status changed from Open to Feedback

seems duplicate of #5611

#2 Updated by Nathan Woodrow about 7 years ago

No this is for the Style Manager dialog.

#3 Updated by Arunmozhi P about 7 years ago

  • File 6273.patchMagnifier added
  • Pull Request or Patch supplied changed from No to Yes

Patch added.

#4 Updated by Arunmozhi P almost 7 years ago

  • % Done changed from 0 to 50

#5 Updated by Giovanni Manghi almost 7 years ago

Hi there,

just for curiosity, there is someone working (or planning to) on this issue?

#3275 is one of the outstanding missing features that was available in the old symbology and missing in the new one (allow select >1 symbol classes and change their symbol in one go). See Switching_from_Old_to_New_Symbology_and_Labeling

#6 Updated by Nathan Woodrow almost 7 years ago

Applied in 41d306be1a82

Sorry it took so long

#7 Updated by Nathan Woodrow almost 7 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 50 to 100
  • Resolution set to fixed
  • Pull Request or Patch supplied changed from Yes to No

#8 Updated by Nathan Woodrow over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF