Bug report #5611

Deleting multiple classified symbols in the style window not working

Added by Carlos da Ponte almost 8 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15184

Description

in the Layer Properties / Style tab (using the new symbology interface) if I classify a layer, then select multiple symbols to delete and click the 'delete' button only the last symbol on the list is deleted.

History

#1 Updated by Giovanni Manghi almost 8 years ago

confirmed on master.

#2 Updated by Paolo Cavallini over 7 years ago

  • Target version set to Version 2.0.0

#3 Updated by Tilman Brock about 7 years ago

Does 7faa1b21 fix this?

#4 Updated by Daniel Vaz over 6 years ago

Yes, you are right. The above commit fix this issue. I can't reproduce it with master.

I think that should be closed.

Thanks

#5 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF