Bug report #6085

Composer does not maintain state of render preview and page zoom

Added by Tim Sutton over 8 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Marco Hugentobler
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System:Linux (Ubuntu) Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:15439

Description

If I save a composer, close the project and then open it again, it forgets the settings for render preview - cache.
It also forgets the page zoom level (maybe not so easy to maintain if the window has changed size).

Associated revisions

Revision cc9f2a62
Added by Sandro Mani over 5 years ago

Call QgsComposer::restoreComposerMapStates in QgsComposer:changeEvent,
not in showEvent (latter does not work reliably with some window
managers, such as openbox) (fix #6085)

Revision 2037c346
Added by Nyall Dawson over 5 years ago

Call QgsComposer::restoreComposerMapStates in QgsComposer:changeEvent,
not in showEvent (latter does not work reliably with some window
managers, such as openbox) (fix #6085)

Cherry-picked from cc9f2a6270b59143000e30f41db1f57e8d900534

History

#1 Updated by Marco Hugentobler over 8 years ago

This is a problem on gnome, the composer does not receive a show event when visible (because to make project loading faster, the composermaps are created in rectangle preview mode and the maps are drawn when the composer is first opened). It works on KDE (and afaik also on windows).

#2 Updated by Nyall Dawson almost 7 years ago

  • Resolution set to up/downstream
  • Target version deleted (Version 2.0.0)
  • Category changed from 33 to Map Composer/Printing

#4 Updated by Anonymous over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF