Bug report #5875

QGIS doesn't use its own GDAL tools and fails if another version of GDAL is installed

Added by Jonathan Ball over 8 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GDAL Tools
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:15336

Description

This issue applies to both Windows 32 and 64 bit and I have tried it on Windows 7, Vista and XP. I have also had the same error with QGIS 1.7x, 1.8 and 1.9.9.

Due to the dependency of another piece of software I MUST have GDAL installed for Python 3.2 independent of QGIS. However, QGIS appears to have its own instalation of GDAL and version 1.9 will even let you specify where the repositories are. However, QGIS does not look for its own GDAL install but tries to use the one referenced by the Windows environment variable regardless of whether I specify an appropriate path (in QGIS 1.9) and despite the fact that I can see the gdal18.dll in the QGIS \\bin folder.

On startup, in QGIS 1.7x I get the error that the module is not compatible with Python 2.5 and in QGIS 1.8 I get the error meesage "Unable to load GdalTolls plugin. The required osgeo [python-gdal] module is missing. Install it and try again."

If I uninstall QGIS and GDAL for Python32, then reinstall just QGIS, the issue goes away until I try to install GDAL for Python32.

I have been told that it ought to be possible to have an independent GDAL instalation alongside QGIS because QGIS uses its own instalation of Python and GDAL, but this does not seem to work. Please can we have an option to tell QGIS which dlls to use for GDAL or, even better, can we have a version of QGIS for Python 3.2?

History

#1 Updated by Alexander Bruy over 8 years ago

Try to set path to GDAL binaries and other files in GDALTools plugin options

#2 Updated by Paolo Cavallini about 8 years ago

  • Target version set to Version 2.0.0

#3 Updated by Giovanni Manghi almost 8 years ago

  • Assignee set to Giuseppe Sucameli

#4 Updated by Paolo Cavallini almost 8 years ago

  • Assignee changed from Giuseppe Sucameli to anonymous -

#5 Updated by Jürgen Fischer over 7 years ago

  • Assignee deleted (anonymous -)

#6 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#7 Updated by Médéric RIBREUX almost 5 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

do you still have this problem ? I can't reproduce it on Windows 7 with QGIS 2.12.1 but perhaps have I got another installation of GDAL...

#8 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF