Bug report #5820

Added MapInfo Tab layer assigned wrong projection

Added by Bo Victor Thomsen over 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:1.8.0 Regression?:No
Operating System:Windows 7 64 bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15299

Description

If I add a MapInfo layer with the (buildt-in) projection EPGS:25832 (UTM32N/ETRS89) it will be assigned a wrong SRS: (properties window)
"
General:
Storage type of this layer: MapInfo File
Source for this layer: C:\\Users\\Bo Victor Thomsen\\epsg25832_sample.TAB
Geometry type of the features in this layer: Polygon
The number of features in this layer: 1
Editing capabilities of this layer: Add Attributes, Fast Access to Features at ID
Extents:
In layer spatial reference system units : xMin,yMin 709652.83,6216521.31 : xMax,yMax 709888.95,6216762.80
Layer Spatial Reference System:
+proj=utm +zone=32 +ellps=GRS80 +towgs84=0,0,0,-0,-0,-0,0 +units=m +no_defs
"
The SRS is wrong:
+proj=utm +zone=32 +ellps=GRS80 +towgs84=0,0,0,-0,-0,-0,0 +units=m +no_defs

It should be:
+proj=utm +zone=32 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs

(minus zero ??)

You can almost double the redraw speed for the layer by changing the SRS to the correct value.
My tabfile contains ca. 70.000 polygons. It takes 22 sec. to redraw with the correct SRS versus 37 sec. with the wrong SRS.
My platform is QGIS 1.8, Windows 7 64 bit.
I've added a small sample with 1 polygon

epsg25832_sample.zip - Tabfile projection EPSG 25832 - 1 polygon (2.08 KB) Bo Victor Thomsen, 2012-06-18 01:33 PM

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

is this a regression? it used to work fine on 1.7.x?

#2 Updated by Bo Victor Thomsen over 7 years ago

I've just reinstalled QGIS 1.7.4. It exhibits the same behaviour with the tab layer:
...
General:
Storage type of this layer: MapInfo File
Source for this layer: C:\\GisData\\NyeData\\LitraPolygoner.TAB
Geometry type of the features in this layer: Polygon
The number of features in this layer: 71424
Editing capabilities of this layer: Fast Access to Features at ID
Extents:
In layer spatial reference system units : xMin,yMin 442334.72,6049844.09 : xMax,yMax 890420.32,6399741.46
Layer Spatial Reference System:
+proj=utm +zone=32 +ellps=GRS80 +towgs84=0,0,0,-0,-0,-0,0 +units=m +no_defs ===========================================================================
No regression but an old error

#3 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Nathan Woodrow almost 7 years ago

Seems to be an issue at the ogr level. Result from ogrinfo -so -al

Had to open data source read-only.                                                                                                                    
INFO: Open of `epsg25832_sample.TAB'                                                                                                                  
      using driver `MapInfo File' successful.                                                                                                         

Layer name: epsg25832_sample                                                                                                                          
Geometry: Unknown (any)                                                                                                                               
Feature Count: 1                                                                                                                                      
Extent: (709652.834000, 6216521.309500) - (709888.947500, 6216762.795500)                                                                             
Layer SRS WKT:                                                                                                                                        
PROJCS["unnamed",                                                                                                                                     
    GEOGCS["unnamed",                                                                                                                                 
        DATUM["Euref_98",                                                                                                                             
            SPHEROID["GRS 80",6378137,298.257222101],                                                                                                 
            TOWGS84[0,0,0,-0,-0,-0,0]],                                                                                                               
        PRIMEM["Greenwich",0],                                                                                                                        
        UNIT["degree",0.0174532925199433]],                                                                                                           
    PROJECTION["Transverse_Mercator"],                                                                                                                
    PARAMETER["latitude_of_origin",0],                                                                                                                
    PARAMETER["central_meridian",9],                                                                                                                  
    PARAMETER["scale_factor",0.9996],                                                                                                                 
    PARAMETER["false_easting",500000],                                                                                                                
    PARAMETER["false_northing",0],                                                                                                                    
    UNIT["Meter",1.0]]                                                                                                                                
DISTNR: Real (4.0)                                                                                                                                    
DISTNAVN: String (40.0)                                                                                                                               
SKOVNR: Real (5.0)                                                                                                                                    
SKOVNAVN: String (80.0)                                                                                                                               
AFDELING: Real (5.0)                                                                                                                                  
LITRA: String (2.0)                                                                                                                                   
LITRAAREAL: Real (15.2)                                                                                                                               
ANV_KODE: String (5.0)                                                                                                                                
ANL_AAR: String (5.0)                                                                                                                                 
ANV_BESK: String (40.0)                                                                                                                               
OPDATERET: String (20.0)                                                                                                                              
BRUGER: String (10.0)                                                                                                                                 
EXPORTDATO: String (10.0)

TOWGS84[0,0,0,-0,-0,-0,0]]

#5 Updated by Giovanni Manghi almost 7 years ago

if is an ogr issue please close this ticket and file it upstream.

Nathan Woodrow wrote:

Seems to be an issue at the ogr level. Result from ogrinfo -so -al

[...]

TOWGS84[0,0,0,-0,-0,-0,0]]

#6 Updated by Bo Victor Thomsen almost 7 years ago

  • Status changed from Feedback to Closed

I agree with Nathan. It's a OGR or Mitab problem. I'll open a ticket at GDAL.

Also available in: Atom PDF