Bug report #5543

OSX several plugins not loading

Added by Howard Frederick over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Python plugins
Affected QGIS version:1.7.4 Regression?:No
Operating System:OSX Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15136

Description

Several plugins do not load in QGIS, e.g. QuickWKT and Spatial Query.

When selected from the menu or toolbar buttons nothing happens. Others reporting this on QGIS.se indicate that it is happening on OSX 10.6, but working fine on Windows.

This happens in QGIS 1.9 as well.

Loading the Guest user and running QGIS (with no plugins, effectively a clean install) doesn't help.

Associated revisions

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

the plugins are 3rd party or core? If are 3rd party then you have to report the issues to the authors and/or to the proper project in this tracker

https://issues.qgis.org/projects

#2 Updated by Howard Frederick over 7 years ago

Spatial Query comes with QGIS 1.7 (see note on clean install) and does not show up in the list on plugins.qgis.org - I assume that means it's core? Can't find a list of 'core' plugins to be sure! QuickWKT is a 3rd party extension, but same behaviour (and there are others).

Should I post this elsewhere?

#3 Updated by Nathan Woodrow over 7 years ago

Yeah SpatialQuery is core.

#4 Updated by Larry Shaffer over 7 years ago

It looks like another plugin that connects the activated() signal to its launching gui elements.

https://github.com/qgis/Quantum-GIS/blob/master/src/plugins/spatialquery/qgsspatialqueryplugin.cpp#L82

That signal is no longer supported under Qt 4.8, which is what QGIS 1.7.4 is built against/bundled with on Mac OS X. I have seen this problem with other plugins (now both C++ and Python).

http://qt-project.org/doc/qt-4.8/qaction.html#signals

I have not tested this, but changing the signal to 'triggered()' might fix the problem.

#5 Updated by Larry Shaffer over 7 years ago

More discussion on this issue:

http://osgeo-org.1560.n6.nabble.com/OSGEO4W-vs-Mac-OS-X-Qt-version-or-34-plugins-slightly-broken-tp4963580.html

Appears to be fixed with newer master (1.8 RC) builds. Not sure what changed between 1.7.4-4 and now. Essentially, the current Mac releases (1.7.4-4 and 1.9 dev-2012/3/11) have no support for Qt3 deprecated code, while other builds have some Qt3 support in the core Qt frameworks supplied by Nokia, because they were compiled with the -qt3support option. I think this allows plugins with deprecated Qt3 code to still work, even if the Qt3Support.framework is not bundled in the Mac app.

All platforms that rely upon the default Qt install from Nokia will have some Qt3 support, allowing the plugins to launch, until Nokia pulls that support from their releases.

#6 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF