Bug report #5520

Wrong boundingbox values in GetCapabilities for empty layers

Added by zicke - over 7 years ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:Paul Blottiere
Category:QGIS Server
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15120

Description

For layers without any feature the bbox calculation for the GetCapabilities request is wrong. The result is some 'nonsense' bbox value. You can still use the wms layer with a correct bbox but QGIS fails to load groups (or the whole wms 'tree') with empty layers since the group bbox is wrong too.


Related issues

Related to QGIS Application - Bug report #10379: Qgis mapserv: Flaky WFS GetFeature Closed 2014-05-28

Associated revisions

Revision da22f7cc
Added by Paul Blottiere about 1 year ago

Fixes #5520 - Invalid BBOX in WMS GetCapabilities

Revision c41a5d07
Added by Paul Blottiere about 1 year ago

Merge pull request #8220 from pblottiere/server_invalid_bbox

[server] Fixes #5520 - Invalid BBOX in WMS GetCapabilities

History

#1 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#2 Updated by Bernhard Ströbl almost 6 years ago

  • Priority changed from Normal to High
  • Target version changed from Version 2.0.0 to Future Release - High Priority
  • Operating System changed from Ubuntu to any

I raised this bug in priority because it is annoying
underlying data change and a layer may become empty (no features in it) in the course of time as well as refilling again
I my case this box is returned:
<EX_GeographicBoundingBox>
<westBoundLongitude>6.42191</westBoundLongitude>
<eastBoundLongitude>6.42191</eastBoundLongitude>
<southBoundLatitude>89.9946</southBoundLatitude>
<northBoundLatitude>89.9946</northBoundLatitude>
</EX_GeographicBoundingBox>

Proposed solution: if layer delivers a bbox larger than the bbox set in the OWS server tab the bbox set in OWS server is returned (IMHO it does not make sense to have layers propagating larger bboxes than the project does)

#3 Updated by Jürgen Fischer over 5 years ago

  • Subject changed from Wrong boundingbox values in GetCapabilities for empy layers to Wrong boundingbox values in GetCapabilities for empty layers

#4 Updated by Jürgen Fischer about 4 years ago

  • Assignee deleted (Marco Hugentobler)

#5 Updated by Giovanni Manghi almost 3 years ago

  • Priority changed from High to Normal
  • Operating System deleted (any)

#6 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#7 Updated by Paul Blottiere about 1 year ago

  • Assignee set to Paul Blottiere

#8 Updated by Paul Blottiere about 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF