Bug report #5365

Line detection fails

Added by Paolo Cavallini over 8 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:15053

Description

Apparently, a DEM layer is mandatory for this analysis, but the interface doe not require it, thus the command fails, and the user has no clue why (besides inspectiong the log):

OTB execution console output
LineSegmentDetection -in /home/paolo/Desktop/butta/otb_samples/orto.jpeg -elev dem -elev.average.value 0 -out /home/paolo/sextante/tempdata/1334501940.421.shp

ERROR: Missing mandatory parameter: elev.dem.path 0
ERROR: Troubles loading parameter, please check your line argument...

fix_error_OTBLineSegmentDetectionAlg.patch Magnifier (1.56 KB) Salvatore Larosa, 2012-04-15 02:56 PM

History

#1 Updated by Julien Malik over 8 years ago

The otb behavior is that the "elev" parameter default to "average", but "dem" is the first choice in the list, and has a mandatory dependency on "dem.path".

Support for default value in ParameterSelection will provide a way to fix this.

Paolo, to make it work, choose "average".

#2 Updated by Salvatore Larosa over 8 years ago

The patch attached seems to fix the issue!

#3 Updated by Paolo Cavallini over 8 years ago

Thanks Julien - now it works without errors, so "average" should be the default.

BTW, with the ortho.jpeg file you provided, no lines are detected, and I do not see options to improve this result (but this must be a totally different problem).

#4 Updated by Paolo Cavallini over 8 years ago

  • Category set to 57

#5 Updated by Julien Malik over 8 years ago

  • Assignee set to Julien Malik

#6 Updated by Julien Malik over 8 years ago

  • Status changed from Open to Resolved

#7 Updated by Julien Malik over 8 years ago

fixed in r127

#8 Updated by Paolo Cavallini over 8 years ago

  • Status changed from Resolved to Feedback

Tried again, still no lines detected. Can you provide a sample image where it works? Thanks.

#9 Updated by Filipe Dias about 7 years ago

Is this still happening?

#10 Updated by Alexander Bruy over 6 years ago

  • Status changed from Feedback to Closed

Closing for lack of feedback. Reopen if necessary

#11 Updated by Paolo Cavallini over 6 years ago

  • Status changed from Closed to Reopened

Please wait until next OTB package will be available. I'll retest it.

#12 Updated by Giovanni Manghi about 6 years ago

  • Project changed from 78 to QGIS Application
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to 2.4.0
  • Category deleted (57)

#13 Updated by Giovanni Manghi about 6 years ago

  • Category set to 120

#14 Updated by Giovanni Manghi about 6 years ago

  • Assignee changed from Julien Malik to Victor Olaya

#15 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Reopened to Closed
  • Resolution set to fixed/implemented

closed for lack of feedback and because it works.

#16 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No

#17 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No

#18 Updated by Giovanni Manghi over 3 years ago

Some providers are being removed from QGIS/Processing (will be available as plugin) and so are their categories in the bug tracker. To not leave them orphaned of a category they are being reassigned to processing/core.

#19 Updated by Giovanni Manghi over 3 years ago

  • Category changed from 120 to Processing/Core

Also available in: Atom PDF